Как настроить балансировку нагрузки по путям с неравной стоимостью EIGRP

Как настроить балансировку нагрузки по путям с неравной стоимостью EIGRP

CiscoEIGRP

Рассмотрим как настроить распределение (балансировку) нагрузки по путям с неравной стоимостью (unequal cost load balancing) в EIGRP на маршрутизаторах Cisco. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

 

Как настроить балансировку нагрузки по путям с неравной стоимостью EIGRP

 

Сценарий

Распределение (балансировка) нагрузки является распространенной задачей в современных сетях, которая позволяет эффективно использовать доступные канальные и буферные ресурсы, а также повышать производительность сети. Балансировка нагрузки — одна из функций протоколов динамической маршрутизации, таких как RIP, OSPF, EIGRP, BGP и т.д. Однако если во всех протоколах реализуется балансировка нагрузки по путям (маршрутам) с равной стоимостью, то EIGRP — это единственный протокол, в функционал которого заложена возможность балансировки нагрузки по путям с неравной стоимостью (unequal cost load balancing). Эта особенность протокола EIGRP на ряду с другими (композитная метрика, алгоритм DUAL, ограниченные рассылки, Protocol Dependent Module — PDM, Relaible Transport Protocol — RTP и другие) выгодно его выделяет для реализации маршрутизации в современных сетях.

 

Задачи

Часть 1. Построение сети и проверка подключения
Часть 2. Настройка процесса маршрутизации EIGRP
Часть 3. Настройка балансировки нагрузки

 

Конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface gigabitEthernet 0/2
ip address 192.168.12.1 255.255.255.0
no shutdown
exit

interface gigabitEthernet 0/0
ip address 192.168.13.1 255.255.255.0
no shutdown
exit

 

Конфигурации R2 после выполнения Части 1
hostname R2
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface gigabitEthernet 0/2
ip address 192.168.23.2 255.255.255.0
no shutdown
exit

interface gigabitEthernet 0/0
ip address 192.168.12.2 255.255.255.0
no shutdown
exit

 

Конфигурации R3 после выполнения Части 1
hostname R3
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface gigabitEthernet 0/2
ip address 192.168.13.3 255.255.255.0
no shutdown
exit

interface gigabitEthernet 0/0
ip address 192.168.23.3 255.255.255.0
no shutdown
exit

 

Конфигурации R1 после выполнения Части 2
router eigrp 1
network 192.168.12.0 0.0.0.255
network 192.168.13.0 0.0.0.255
exit

 

Конфигурации R2 после выполнения Части 2
router eigrp 1
network 192.168.12.0 0.0.0.255
network 192.168.23.0 0.0.0.255
exit

 

Конфигурации R3 после выполнения Части 2
router eigrp 1
network 192.168.13.0 0.0.0.255
network 192.168.23.0 0.0.0.255
exit

 

Конфигурации R1 после выполнения Части 3
interface gigabitEthernet 0/0
bandwidth 100000
exit
router eigrp 1
variance 9
exit

 

Конфигурации R3 после выполнения Части 3
interface gigabitEthernet 0/2
bandwidth 100000
exit

 

Проверка и тестирование балансировки нагрузки EIGRP
show ip route
show interfaces gigabitEthernet 0/0
show ip eigrp topology
show ip eigrp topology 192.168.23.0
show ip eigrp topology all-links

 

Спасибо за уделенное время на прочтение статьи о том, как настроить распределение (балансировку) нагрузки по путям с неравной стоимостью (unequal cost load balancing) в EIGRP на Cisco!

 

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
CiscoEIGRP

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню