rip

Как настроить RIP на маршрутизаторе Cisco

RIP

RIP (Routing Information Protocol) — это один из протоколов маршрутизации, которые необходимо понять, если вы хотите пройти экзамен Cisco CCNA. Если вы не знаете, как работает RIP, я предлагаю сначала прочитать предыдущую статью, где я объясню, как работает RIP. В этой статье я покажу вам, как настроить RIP на маршрутизаторе Cisco. Вот топология, которую я буду использовать:

 

rip-3-routers

 

Выше мы видим 3 маршрутизатора под названием R1, R2 и R3. У нас несколько сетей, поэтому будет возможность объявлять через RIP. Сначала давайте настроим все интерфейсы:

R1>enable
R1#configure terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown

 

R2>enable
R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface FastEthernet 1/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#exit

 

R3>enable
R3#configure terminal
R3(config)#interface fastEthernet 0/0
R3(config-if)#no shutdown
R3(config-if)#ip address 172.16.2.3 255.255.255.0
R3(config-if)#exit
R3(config)#interface fastEthernet 1/0
R3(config-if)#no shutdown
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#exit

Прежде чем продолжить RIP, мы проверим таблицы маршрутизации:

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
ia - IS-IS inter area, * - candidate default,
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet1/0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0

 

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
ia - IS-IS inter area, * - candidate default,
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/0
C 192.168.23.0/24 is directly connected, FastEthernet1/0

 

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
ia - IS-IS inter area, * - candidate default,
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.2.0 is directly connected, FastEthernet0/0
C 192.168.23.0/24 is directly connected, FastEthernet1/0

 

Наши маршрутизаторы знают только одну вещь – их напрямую подключенные интерфейсы. Давайте настроим RIP и посмотрим, что произойдет:

R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 172.16.1.0

 

R2(config)#router rip
R2(config-router)#network 192.168.12.0

 

 

Мы используем команду router rip для перехода к конфигурации RIP. Следующим шагом будет использование команды network, которая выполняет две функции:

Давайте увеличим R1 и R2, чтобы я мог объяснить это немного подробнее …

 

rip-send-updates-both-ways

 

 

  1. Все сети, указанные с помощью команды network, будут объявляться в RIP для других маршрутизаторов.
  2. Обновления RIP будут отправляться на интерфейс, IP-адрес которого попадает в диапазон сети, указанной с помощью команды network.

 

R1 (config-router) #network 192.168.12.0

 

Когда я наберу «network 192.168.12.0», я поставлю все сети, которые попадают в диапазон 192.168.12.0, в базу данных RIP. Интерфейс FastEthernet 1/0 имеет адрес из диапазона 192.168.12.0/24, поэтому он будет размещен в базе данных RIP. Он также отправит обновления RIP на этот интерфейс.

 

R1 (config-router) #network 172.16.1.0

 

Сеть 172.16.1.0/24, которая настроена на интерфейсе FastEthernet 0/0, входит в диапазон 172.16.1.0, поэтому она будет помещена в базу данных RIP.

Мы также отправим обновления RIP на интерфейс FastEthernet 0/0. Это может показаться немного глупым, потому что нет другого маршрутизатора, подключенного к этому интерфейсу, то есть нет смысла отправлять обновления RIP в этом направлении. Я разъясню это немного позже.

Давайте посмотрим на R2:

 

rip-advertise-one-network

 

 

R2 (config-router) #network 192.168.12.0

 

На R2 я использовал только команду network. Это означает, что R2 поместит 192.168.12.0/24 в базу данных RIP и отправит обновления RIP на свой интерфейс FastEthernet 0/0. В настоящий момент он не будет объявлять сеть 192.168.23.0/24 в RIP и не будет отправлять обновления RIP на интерфейс FastEthernet 1/0.

Давайте проверим таблицы маршрутизации R1 и R2!

 

R1# show ip route rip

 

R2# show ip route rip
R 172.16.0.0/16 [120/1] via 192.168.12.1, 00:00:21, FastEthernet 0/0

 

Вместо того, чтобы вводить show ip route вы также можете использовать show ip route rip. Это покажет только информацию RIP в таблице маршрутизации. Как вы можете видеть, R1 не узнал ничего от R2. Это связано с тем, что сеть 192.168.23.0/24 не объявлена ​​на R2.

R2 узнал сеть 172.16.0.0/16. Почему мы видим 172.16.0.0/16, а не 172.16.1.0/24? Имейте в виду, что по умолчанию в RIP работает версия 1, которая является классовой. Он НЕ отправляет маску подсети вместе с обновлениями маршрутизации. Поскольку 172.16.1.0/24 находится в диапазоне сетей класса B, она будет объявляться как 172.16.0.0/16.

Я настрою RIP версию 2 позже, чтобы вы могли видеть разницу между бесклассовой и классовой версиями протокола.

В любом случае давайте посмотрим, можем ли мы сделать так, чтобы R1 узнал о 192.168.23.0/24:

 

R2 (config) #router rip
R2 (config-router) #network 192.168.23.0

 

Я буду использовать команду network:

 

rip-advertise-two-networks

 

Когда я использую команду network 192.168.23.0, она поместит 192.168.23.0/24 в базу данных RIP и отправит обновления RIP на интерфейс FastEthernet 1/0. Давайте проверим R1:

 

R1#show ip route rip
R 192.168.23.0/24 [120/1] via192.168.12.2, 00:00:16, FastEthernet 1/0

 

Теперь R1 знает, как достичь этой сети. Давайте подробнее рассмотрим эту запись

 

R 192.168.23.0/24

 

«R» означает, что эта запись была получена через RIP, 192.168.23.0/24 — это сеть, которую мы получили.

 

[120/1]

 

Первое число (120) — это административное расстояние. Второе число (1) является метрикой. RIP использует «счетчик переходов» в качестве показателя, поэтому сеть 192.168.23.0/24 находится на расстоянии одного перехода.

 

via 192.168.12.2

 

Это IP-адрес следующего перехода. Если мы хотим достичь сети 192.168.23.0/24, мы отправим IP-пакеты в направлении 192.168.12.2.

 

00:00:16

 

Это время с момента последнего обновления для этой записи. RIP отправляет обновление каждые 30 секунд, поэтому значение никогда не превысит 29 секунд.

 

FastEthernet 1/0

 

Это исходящий интерфейс. Когда мы хотим достичь сети 192.168.23.0/24, мы будем использовать этот интерфейс для исходящего трафика.

Есть одна последняя вещь, которую я хочу рассказать вам о команде network. Покажу вам R2 еще раз:

 

router-two-interfaces

R2 имеет эти два интерфейса, и я использовал команду network дважды:

 

R2 (config-router) #network 192.168.12.0
R2 (config-router) #network 192.168.23.0

 

Это прекрасно работает, как вы видите. Я также мог бы использовать только одну команду network:

 

R2 (config-router) #network 192.168.0.0

 

Если бы я указал сеть 192.168.0.0, у меня был бы тот же результат. Обе сети 192.168.12.0/24 и 192.168.23.0/24 попадают в этот диапазон, поэтому RIP будет активирован для обоих интерфейсах, и будут объявлены обе сети ​​192.168.12.0/24 и 192.168.23.0/24.

Даже следующая сетевая команда будет работать:

 

R2(config-router)#network 0.0.0.0

 

Сеть 0.0.0.0 в основном означает «включить RIP на всех интерфейсах и объявлять все». Это то, что мы называем «подход дробовика».

Не используйте что-то вроде «network 0.0.0.0» в производственной сети. Она будет работать, но это означает, что всякий раз, когда кто-то добавляет новый интерфейс и настраивает IP-адрес на нем, он будет объявляться в RIP. 

У нас все еще есть один маршрутизатор для настройки, поэтому давайте включим RIP на R3?

 

R3(config)#router rip
R3(config-router)#network 172.16.2.0
R3(config-router)#network 192.168.23.0

 

Сначала я настрою команды network. Теперь давайте посмотрим, что мы находим в наших таблицах маршрутизации:

 

R1#show ip route rip
R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:21, FastEthernet 1/0
R2 # show ip route rip
R 172.16.0.0/16 [120/1] via 192.168.23.3, 00:00:15, FastEthernet 1/0
[120/1] via 192.168.12.1, 00:00:11, FastEthernet 0/0

 

R3#show ip route rip
R 192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:26, FastEthernet 1/0

 

Здесь есть несколько интересных вещей:

  • R1 не узнал о сети 172.16.2.0/24.
  • R3 не узнал о сети 172.16.1.0/24.
  • R2 имеет 172.16.0.0/16 в своей таблице маршрутизации с двумя IP-адресами следующего перехода:
    1) 192.168.23.3.
    2) 192.168.12.1.

На данный момент мы запускаем RIP версию 1, которая является классовой. Это означает, что R1 объявляет 172.16.1.0/24 как 172.16.0.0, а R3 объявляет 172.16.2.0/24 как 172.16.0.0.

Так что же делает R2 с этой информацией? Всякий раз, когда вы узнаете о сети из двух разных источников с одинаковой метрикой, ваш маршрутизатор будет выполнять балансировку нагрузки. Например, когда R2 получает IP-пакет, предназначенный для 172.16.1.1, он может отправить его на R3, и тот будет отброшен.

R1 и R3 не узнают о сети 172.16.1.0/24 или 172.16.2.0/24, но почему это происходит?

 

rip-classful-advertisement-1

R1 и R3 объявляет 172.16.0.0 в сторону R2. R2 хранит эту информацию в своей таблице маршрутизации, но не объявляет 172.16.0.0 в сторону R1 или R3 из-за механизма «расщепление горизонта». Вы не рассказываете своему соседу то, что вы узнали от него.

Итак, как это исправить? Мы должны убедиться, что R1 и R3 отправляют маску подсети с их обновлениями RIP. Это время для RIP версии 2, потому что оно бесклассовое.

Существует очень полезная команда для проверки того, какие протоколы маршрутизации вы используете:

 

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 21 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface                  Send Recv Triggered RIP Key-chain
FastEthernet0/0              1   1 2
FastEthernet1/0              1   1 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.12.0
Routing Information Sources:
Gateway         Distance       Last Update
192.168.12.2      120              00:00:03
Distance: (default is 120)

 

Show ip protocols  — очень полезная команда, поэтому я рекомендую записать ее где-нибудь. Это касается не только RIP, но и информации о любом другом протоколе маршрутизации. Мы видим, что мы запускаем RIPv1 и что мы отправляем обновления RIP на интерфейс FastEthernet 0/0 и 1/0. Вы также можете видеть сети, которые мы объявляем (172.16.0.0 и 192.168.12.0).

Давайте теперь переключим наши маршрутизаторы на RIP версии 2:

 

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary

 

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary

 

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary

 

По умолчанию версия RIPv2 будет вести себя классово и не будет отправлять маску подсети. Мне нужно ввести no auto-summary, чтобы заставить его вести себя как бесклассовый протокол и отправить маску подсети с ее обновлениями RIP.

 

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 19 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
IInterface                  Send Recv Triggered RIP Key-chain
FastEthernet0/0              1    2
FastEthernet1/0              1    2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.12.0
Routing Information Sources:
Gateway          Distance Last Update
192.168.12.2        120       00:00:23
Distance: (default is 120)

 

Вы можете видеть, что теперь мы используем RIPv2. Давайте посмотрим, есть ли разница в наших таблицах маршрутизации:

 

R1#show ip route rip
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.2.0 [120/2] via 192.168.12.2, 00:00:24, FastEthernet1/0
R 192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:24, FastEthernet1/0

 

R2#show ip route rip
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 192.168.12.1, 00:00:08, FastEthernet0/0
R 172.16.2.0 [120/1] via 192.168.23.3, 00:00:26, FastEthernet1/0

 

[codeR3#show ip route rip
R  192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:16, FastEthernet1/0
172.16.0.0/24 is subnetted, 2 subnets
R  172.16.1.0 [120/2] via 192.168.23.2, 00:00:16, FastEthernet1/0[/code]

 

Так выглядит лучше. Вы можете видеть, что R2 узнал о сети 172.16.1.0/24 и 172.16.2.0/24. Это связано с тем, что R1 и R3 объявляют 172.16.1.0/24 и 172.16.2.0/24, а не 172.16.0.0. R1 и R3 также узнали о сетях друг друга.

Теперь вы знаете, как настроить RIP, и вы видели некоторые команды show для поиска информации. Мы также можем использовать команду debug для просмотра в реальном времени того, что делает наш маршрутизатор. Давайте посмотрим на пример RIP.

 

R2#debug ip rip
RIP protocol debugging is on

 

Debug IP rip — это то, как мы его включаем. Вы увидите такие сообщения:

 

R2#
RIP: received v2 update from 192.168.12.1 on FastEthernet0/0
172.16.1.0/24 via 0.0.0.0 in 1 hops

 

Вот что вы видите, когда R2 получает обновление RIP от R1. Мы узнаем о сети 172.16.1.0/24.

 

RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.2)
RIP: build update entries
172.16.2.0/24 via 0.0.0.0, metric 2, tag 0
192.168.23.0/24 via 0.0.0.0, metric 1, tag 0

 

Это обновление RIP, которое R2 отправит в направлении R1. Оно несет информацию о сетях 172.16.2.0/24 и 192.168.23.0/24. В случае, если вам интересно, что означает 224.0.0.9. RIPv2 использует многоадресную рассылку для доставки. 224.0.0.9 — это многоадресный адрес для рассылки сообщений RIPv2.

И последнее, но не менее важное: я хочу показать вам, как настраивать суммирование при использовании RIP. Вот топология, которую мы будем использовать:

 

rip-summarization-1

 

На R1 у меня есть сеть 172.16.0.0/24 и 172.16.1.0/24. Вот конфигурация RIP перед суммированием:

 

R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.12.0
R1(config-router)#network 172.16.0.0

 

R2 (config-router) #version 2
R2 (config-router) #no auto-summary
R2 (config-router) #network 192.168.12.0

 

Я буду использовать версию 2 и отключу автосуммирование. Таблица маршрутизации R2 будет выглядеть так:

 

R2#show ip route rip
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.0.0 [120/1] via 192.168.12.1, 00:00:00, FastEthernet0/0
R 172.16.1.0 [120/1] via 192.168.12.1, 00:00:00, FastEthernet0/0

 

Вы видите обе сети. Теперь давайте настроим ручное суммирование:

 

R1(config)#interface fastEthernet 1/0
R1(config-if)#ip summary-address rip 172.16.0.0 255.255.0.0

 

Используйте команду ip summary-address rip для настройки суммирования вручную, мы делаем это на исходящем интерфейсе в направлении R2. Давайте снова проверим таблицу маршрутизации R2:

 

R2#show ip route rip
R 172.16.0.0/16 [120/1] via 192.168.12.1, 00:00:03, FastEthernet0/0

 

Мы теперь видим результат объявления суммарного маршрута. Объявление суперсети 172.16.0.0/16 не очень эффективно, поскольку этот адрес охватывает все сети между 172.16.0.0 и 172.16.255.255. Всякий раз, когда R2 получает IP-пакет с адресом назначения, который соответствует этой суперсети, он будет перенаправлен в R1. Например, IP-пакет с адресом 172.16.99.99 будет перенаправлен R2 в R1. Однако R1 отбросит этот IP-пакет, потому что он не имеет ничего в своей таблице маршрутизации, чтоб соответствывало адресу 172.16.99.99. Ниже приводятся более эффективные настройки:

 

R1(config)#interface fastEthernet 1/0
R1(config-if)#no ip summary-address rip 172.16.0.0 255.255.0.0
R1(config-if)#ip summary-address rip 172.16.0.0 255.255.254.0

 

Суперсеть 172.16.0.0/23 более конкретна, поскольку охватывает только 172.16.0.0/24 и 172.16.1.0/24. Вот как это выглядит R2:

 

R2#show ip route rip
172.16.0.0/23 is subnetted, 1 subnets
R 172.16.0.0 [120/1] via 192.168.12.1, 00:00:22, FastEthernet0/0

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University.

 

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

Устранение неполадок в RIP

153
0
В этой статье мы продолжим разбирать RIP, старый протокол маршрутизации, который использует количество переходов в качестве своей метрики. В отличие…

Немного о команде offset-list

97
0
При запуске протокола маршрутизации, такого как EIGRP или OSPF, вы можете влиять на метрику протокола маршрутизации, изменяя пропускную способность bandwidth…
TTL

Объяснение TTL в пакетах EIGRP и RIP

119
0
Если вы когда-либо просматривали захват пакетов EIGRP или RIP, вы могли заметить, что значение TTL (время жизни) равно 2. Вероятно,…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Most Viewed Posts
Меню