TTL

Объяснение TTL в пакетах EIGRP и RIP

RIP

Если вы когда-либо просматривали захват пакетов EIGRP или RIP, вы могли заметить, что значение TTL (время жизни) равно 2. Вероятно, вы ожидали увидеть TTL равным 1, поскольку эти многоадресные пакеты не маршрутизируются между подсетями. В этой статье я покажу вам, почему эти пакеты имеют TTL равное 2.

Чтобы продемонстрировать это, я буду использовать следующее соединение маршрутизаторов и топологию типа «звезда» (hub-and-spoke):

 

frame-relay-hub-and-spoke

 

У нас есть один центральный маршрутизатор и два удаленных маршрутизатора. Сначала я настрою Frame relay, используя физические интерфейсы и одну подсеть:

 

Hub(config)#interface serial 0/0
Hub(config-if)#encapsulation frame-relay
Hub(config-if)#ip address 192.168.123.1 255.255.255.0
Hub(config-if)#no shutdown

 

Spoke1(config)#interface serial 0/0
Spoke1(config-if)#encapsulation frame-relay
Spoke1(config-if)#ip address 192.168.123.2 255.255.255.0
Spoke1(config-if)#no shutdown

 

Spoke2(config)#interface serial 0/0
Spoke2(config-if)#encapsulation frame-relay
Spoke2(config-if)#ip address 192.168.123.3 255.255.255.0
Spoke2(config-if)#no shutdown

Мы сконфигурируем EIGRP на всех маршрутизаторах:

 

Hub, Spoke1 и Spoke2:
(config)#router eigrp 123
(config-router)#network 192.168.123.0

 

Теперь установлено соседство между Hub/Spoke1 и Hub/Spoke2. Давайте посмотрим на захваченные пакеты EIGRP в Wireshark, чтобы посмотреть, как выглядит TTL:

 

eigrp-multicast-packet-ttl-2

 

Как вы можете видеть, TTL равен 2, но почему? TTL равный 1 будет достаточно, поскольку эти пакеты не маршрутизируются между подсетями. Ответ на этот вопрос заключается в том, что мы нуждаемся в этом для связи между двумя удаленными (spoke) маршрутизаторами.

Чтобы продемонстрировать это, мы настроим EIGRP на маршрутизаторах spoke1 и spoke2, чтобы они стали соседями, и снова проверим захваченные пакеты в Wireshark. Прежде чем удаленные маршрутизаторы смогут стать соседями, они требуют настройки отображения frame-relay вручную:

 

Spoke1(config)#interface serial 0/0
Spoke1(config-if)#frame-relay map ip 192.168.123.3 201
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#frame-relay map ip 192.168.123.2 301

 

Spoke1 и Spoke2 теперь могут связаться друг с другом. Мы будем использовать команду EIGRP neighbor, чтобы убедиться, что все маршрутизаторы стали соседями друг с другом:

 

Hub(config)#router eigrp 123
Hub(config-router)#neighbor 192.168.123.2 serial 0/0
Hub(config-router)#neighbor 192.168.123.3 serial 0/0

 

Spoke1(config)#router eigrp 123
Spoke1(config-router)#neighbor 192.168.123.1 serial 0/0
Spoke1(config-router)#neighbor 192.168.123.3 serial 0/0

 

Spoke2(config)#router eigrp 123
Spoke2(config-router)#neighbor 192.168.123.1 serial 0/0
Spoke2(config-router)#neighbor 192.168.123.2 serial 0/0

 

Как вы можете видеть, удаленные маршрутизаторы Spoke1 и Spoke2 стали смежными:

 

Spoke1#
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.123.1 (Serial0/0) is up: new adjacency

 

Spoke2#
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 123: Neighbor 192.168.123.2 (Serial0/0) is up: new adjacency

 

Вернемся к Wireshark и посмотрим на пакет EIGRP от Spoke1 до Spoke2. Первые пакеты — это пакеты Приветствия (Hello packets), который Hub получает от Spoke1:

 

eigrp-spoke-ttl-2

 

Как вы можете видеть, пакет Приветствия отправляется с Spoke1 на Spoke2, и он был получен на DLCI 102 на центральном маршрутизаторе, он имеет TTL равный 2. Этот пакет будет перенаправлен центральным маршрутизатором на Spoke2, и он будет выглядеть так:

 

eigrp-spoke-ttl-1

 

Этот вывод Wireshark показывает тот же IP-пакет со Spoke1 на Spoke2, но он отправляется центральным маршрутизатором на DLCI 103. Как вы можете видеть, TTL был уменьшен и имеет значение равное 1. Если бы Spoke1 создал пакет с TTL 1, тогда маршрутизатор Hab не смог бы переслать его на Spoke2.

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University.

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню