OSPF into RIP

Как настроить перераспределение между OSPF и RIP

RIP

В этой статье мы рассмотрим перераспределение между OSPF и RIP. Вот топология, которую мы будем здесь использовать:

 

ospf-rip-redistribution-r1-r2-r3

 

Начнем с перераспределения между OSPF и RIP.

Но для начала показываю вам настройки маршрутизаторов:

 

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R2(config)#router ospf 1
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0

 

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.23.0

 

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 3.3.3.0
R3(config-router)#network 192.168.23.0

 

Ничего необычного, OSPF и RIP объявили свои сети.

R1#show ip route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0

 

R2#show ip route

Gateway of last resort is not set

C 192.168.12.0/24 is directly connected, FastEthernet0/0
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 192.168.12.1, 00:11:05, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/1] via 192.168.23.3, 00:00:20, FastEthernet1/0
C 192.168.23.0/24 is directly connected, FastEthernet1/0

 

R3#show ip route

Gateway of last resort is not set

3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
C 192.168.23.0/24 is directly connected, FastEthernet0/0

 

Видим, что маршрутизатор R2  взял информацию RIP и OSPF. Время для перераспределения!

 

R2(config)#router rip
R2(config-router)#redistribute ?
bgp Border Gateway Protocol (BGP)
connected Connected
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
metric Metric for redistributed routes
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
route-map Route map reference
static Static routes
<cr>

 

Сначала я собираюсь перераспределить OSPF в RIP. Я могу выбрать множество разных протоколов, когда использую команду redistribute.

 

R2(config)#router rip
R2(config-router)#redistribute ospf 1 metric 5

 

Вот как я перераспределяю OSPF (первый процесс) в RIP. Я устанавливаю метрику — количество переходов — равным 5-ти. Помните, что начальная метрика по умолчанию для RIP равна бесконечности. Если я никакую метрику не укажу, перераспределение не удастся!

 

R2(config)#router rip
R2(config-router)#default-metric 5

 

Я также мог бы использовать команду default-metric, чтобы установить подсчет переходов по умолчанию для всего, что я перераспределяю.

 

R3#show ip route rip
R 192.168.12.0/24 [120/5] via 192.168.23.2, 00:00:00, FastEthernet0/0
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/5] via 192.168.23.2, 00:00:00, FastEthernet0/0

 

Такова таблица маршрутизации R3. Вы видите сети OSPF, которые перераспределяются в RIP. Вы также можете увидеть начальную метрику (количество переходов), которая равна 5.

 

R2(config)#router ospf 1
R2(config-router)#redistribute rip subnets

 

Давайте теперь перераспределим RIP в OSPF. Я могу использовать команду redistribute rip subnets. Ключевое слово subnets необходимо, потому что в противном случае OSPF будет перераспределять только классовые сети. Я хочу, чтобы он перераспределял также и бесклассовые сети, поэтому я добавил subnets.

 

R1#show ip route ospf
3.0.0.0/24 is subnetted, 1 subnets
O E2 3.3.3.0 [110/20] via 192.168.12.2, 00:00:21, FastEthernet0/0
O E2 192.168.23.0/24 [110/20] via 192.168.12.2, 00:00:21, FastEthernet0/0

 

 

Давайте посмотрим на маршрутизатор R1. Вы можете увидеть информацию OSPF в таблице маршрутизации. Они отображаются как внешние маршруты второго типа. Значение стоимости (cost — метрика, используемая протоколом OSPF) маршрута равно 20 по умолчанию. OSPF немного сложнее, чем RIP, и в нем есть разница между внутренними и внешними маршрутами.

Если маршруты перераспределяются в OSPF с указанием второго типа, то каждый маршрутизатор в домене OSPF будет видеть одинаковое значение метрики для всех внешних сетей. Если маршруты перераспределяются в OSPF с указанием первого типа, тогда значения метрики для внешних сетей могут варьироваться от маршрутизатора к маршрутизатору.

Сводная таблица со всеми командами настройки адресации, маршрутизации и перераспределения маршрутов для всех маршрутизаторов:

 

R1 R2 R3
Конфигурация для каждого маршрутизатора hostname R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.255 area 0
!
end
hostname R2
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
!
router ospf 1
network 192.168.12.0 0.0.0.255 area 0
redistribute rip subnets
!
router rip
version 2
no auto-summary
network 192.168.23.0
redistribute ospf 1 metric 5
default-metric 5
!
end
hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
!
router rip
version 2
network 3.3.3.0
network 192.168.23.0
!
end

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University.

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

RIP

Обзор протокола RIP (Routing Information Protocol)

187
3 комментария
Описание RIP (Routing Information Protocol) является старым протоколом дистанционно-векторным маршрутизации. В качестве метрики используется количество переходов, которое ограничено максимум 15-ю…

Устранение неполадок в RIP

173
0
В этой статье мы продолжим разбирать RIP, старый протокол маршрутизации, который использует количество переходов в качестве своей метрики. В отличие…

Немного о команде offset-list

126
0
При запуске протокола маршрутизации, такого как EIGRP или OSPF, вы можете влиять на метрику протокола маршрутизации, изменяя пропускную способность bandwidth…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Most Viewed Posts
Меню