Устранение неполадок в RIP

Устранение неполадок в RIP

RIP

В этой статье мы продолжим разбирать RIP, старый протокол маршрутизации, который использует количество переходов в качестве своей метрики. В отличие от OSPF или EIGRP, RIP не устанавливает отношения смежности с соседними маршрутизаторами. Большинство проблем в RIP связаны с отсутствием информации о маршрутах.

Вот несколько вещей, которые могут пойти не так во время работы с RIP:

  • Неправильные сети при настройке команд network: команда network используется для того, чтобы указать RIP, какие сети объявляются, а также куда отправлять обновления маршрутизации RIP. Неправильные (или несуществующие) объявленные сети вызовут проблемы.
  • Выключенный интерфейс: сеть на выключенном интерфейсе не будет объявляться.
  • Пассивный интерфейс: интерфейс, который настроен как пассивный, не отправляет обновления RIP.
  • Несоответствие версии: RIP имеет две версии, оба маршрутизатора должны использовать одну и ту же версию.
  • Максимальное количество переходов: когда количество переходов равно или превышает 16, сеть считается недостижимой.
  • Фильтрация маршрутов: фильтры могут помешать отправке или получению обновлений RIP.
  • Аутентификация: оба маршрутизатора RIP должны иметь одинаковые параметры аутентификации.
  • Расщепление горизонта (split horizon): Сети, которые маршрутизатор получает через интерфейс, не объявляются тот же интерфейс назад.
  • Автоматическое суммирование (Auto-summarization): появляются проблемы с несмежными (discontigious) подсетями.

 

Давайте рассмотрим все эти проблемы и я покажу вам, как их найти и исправить.

 

Проблема с командой network

Я буду использовать эти два маршрутизатора:

 

r1-r2-loopback-behind-r2

 

Предполагается, что R1 должен узнать о 2.2.2.0/24, но в его таблице маршрутизации ничего нет:

 

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

 

Всегда полезно проверить, какие интерфейсы RIP были включены, а какие – нет:

 

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 0 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.21.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 26 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)

 

Show ip protocols — это быстрый способ проверить, какие интерфейсы были включены в RIP. Как вы можете видеть, RIP работает на R1 и R2. Присмотримся на работу сетей. Видим, что на R1 настроена неправильная сеть. Давайте исправлять это:

 

R1(config)#router rip
R1(config-router)#no network 192.168.21.0
R1(config-router)#network 192.168.12.0

 

Посмотрим, помогло ли это:

 

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:17, FastEthernet0/0

 

Проблема решена!

Извлеченный урок: проверять, что сети правильно объявлены (команды network).

 

Проблема с интерфейсом RIP

Идем дальше, все те же два маршрутизатора:

 

r1-r2-loopback-behind-r2

 

Как и в предыдущем примере, R1 должен узнать об 2.2.2.0/24, но в таблице маршрутизации ничего нет:

 

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

 

Проверяем, правильно ли настроены сети:

 

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                    Send Recv Triggered RIP Key-chain
FastEthernet0/0            2      2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.12.0
Routing Information Sources:
Gateway               Distance    Last Update
192.168.12.2             120          00:00:56
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 6 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                   Send Recv Triggered RIP Key-chain
FastEthernet0/0          2       2
Loopback0                 2       2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway            Distance         Last Update
192.168.12.1         120               00:00:03
Distance: (default is 120)

 

Здесь нет проблем, объявляются правильные сети. Давайте проверим R2, так как это маршрутизатор, который должен объявлять сеть 2.2.2.0/24:

 

R2#show ip rip database
192.168.12.0/24 auto-summary
192.168.12.0/24 directly connected, FastEthernet0/0

 

База данных RIP — хорошее место для проверки. Если сети нет в базе данных, то ее нельзя объявить. У R2 действительно была правильная команда network, поэтому сеть должна быть в своей базе данных. Если вы не видите ее здесь, то скорее всего проблема связана с интерфейсом. Давайте проверим это:

 

R2#show ip interface brief | include Loopback0
Loopback0 2.2.2.2 YES manual administratively down down

 

А вот и проблема. Интерфейс не работает. RIP не будет размещать сеть в своей базе данных, когда интерфейс выключен. Давайте исправим это:

 

R2(config)#interface loopback 0
R2(config-if)#no shutdown

 

Посмотрим на базу данных RIP:

 

R2#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24 directly connected, Loopback0
192.168.12.0/24 auto-summary
192.168.12.0/24 directly connected, FastEthernet0/0

 

Теперь можно объявлять в R1. Давайте проверим R1:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:19, FastEthernet0/0

 

Проблема решена! Извлеченный урок: убедитесь, что ваши интерфейсы включены и работают правильно.

 

Проблема с пассивным интерфейсом RIP

Давайте проверим следующую проблему, те же два маршрутизатора:

 

r1-r2-loopback-behind-r2 - Устранение неполадок в RIP

 

Та же задача, R1 не узнать об 2.2.2.0 /24:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

 

Пусто. Давайте снова проверим вывод команды show ip protocols:

 



 

[code]R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface             Send Recv Triggered RIP Key-chain
Loopback0            2       2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
192.168.12.1 120 00:49:15
Distance: (default is 120)

 

Вывод команды show ip protocols очень полезен для устранения неполадок. Вы можете увидеть, что сети настроены правильно, но у R2 есть пассивный интерфейс. Это не позволяет ничего объявить. Давайте исправим это:

 

R2(config)#router rip
R2(config-router)#no passive-interface FastEthernet 0/0

 

Давайте проверим R1:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:12, FastEthernet0/0

 

Проблема решена! Извлеченный урок: убедитесь, что интерфейсы, которые подключаются к другим RIP-маршрутизаторам, не настроены как пассивные.

 

Несоответствие версий RIP

Те же маршрутизаторы:

 

r1-r2-loopback-behind-r2

 

R1 не получает информации о 2.2.2.0/24:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

 

Давайте проверим вывод команды show ip protocols на R1 и R2:

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive version 1
Interface                     Send Recv Triggered RIP Key-chain
FastEthernet0/0             1      1
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.12.0
Routing Information Sources:
Gateway            Distance     Last Update
192.168.12.2          120           00:01:33
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                  Send Recv Triggered RIP Key-chain
FastEthernet0/0          2      2
Loopback0                  2     2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway                Distance     Last Update
192.168.12.1             120           01:03:49
Distance: (default is 120)

 

Если вы посмотрите внимательно, то увидите, что у нас есть несоответствие версии. R1 использует RIP версии 1, в то время как R2 использует RIP версии 2. Давайте исправим это:

 

R1 (config) #router rip
R1 (config-router) #version 2

Это должно решить проблему.

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:20, FastEthernet0/0

 

Извлеченный урок: убедитесь, что вы используете RIP одинаковой версии на обеих сторонах.

 

Ошибка с количеством переходов

Те же маршрутизаторы:

 

r1-r2-loopback-behind-r2

 

Опять же R1 не получает 2.2.2.0/24:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

 

Давайте проверим show ip protocols:

 

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 22 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                Send Recv Triggered RIP Key-chain
FastEthernet0/0       2       2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.12.0
Routing Information Sources:
Gateway              Distance          Last Update
192.168.12.2           120                00:00:27
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Outgoing routes will have 15 added to metric
Sending updates every 30 seconds, next due in 4 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                 Send   Recv Triggered RIP Key-chain
FastEthernet0/0         2        2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway               Distance             Last Update
192.168.12.1           120                    00:00:34
Distance: (default is 120)

 

Кажется, все в порядке. Правильные сети, одна и та же версия, нет пассивных интерфейсов.

Давайте проверим, находится ли сеть в базе данных RIP R2:

 

R2#show ip rip database
2.0.0.0/8 auto-summary
2.2.2.0/24 directly connected, Loopback0
192.168.12.0/24 auto-summary
192.168.12.0/24 directly connected, FastEthernet0/0

 

Она находится в базе данных RIP. Это хороший случай для отладки:

 

R1#debug ip rip
RIP protocol debugging is on

RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
2.2.2.0/24 via 0.0.0.0 in 16 hops (inaccessible)

 

R1 получает обновление, но сеть 2.2.2.0/24 имеет количество переходов, равное 16. Эта сеть не может быть установлена в таблицу маршрутизации. Эта проблема может возникнуть в больших сетях, но для нашего случая я использовал список смещений:

 

R2(config)#router rip
R2(config-router)#no offset-list 0 out 15

 

Это должно устранить проблему:

 

R1#
RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
2.2.2.0/24 via 0.0.0.0 in 1 hops

 

R1 теперь показывает количество переходов равное 1:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:04, FastEthernet0/0

 

Извлеченный урок: количество переходов 16 не допустимо для утилиты. Если сеть небольшая, проверьте списки смещения, которые увеличивают метрику.

 

Ошибка аутентификации RIP

И снова

 

r1-r2-loopback-behind-r2

 

R1 снова не получает сеть 2.2.2.0/24:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

 

Здесь все нормально … давайте проверим show ip protocols:

 

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                 Send Recv Triggered RIP Key-chain
FastEthernet0/0          2     2                           MY_CHAIN
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.12.0
Routing Information Sources:
Gateway              Distance            Last Update
192.168.12.2           120                  00:01:01
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 12 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                   Send Recv Triggered RIP Key-chain
FastEthernet0/0          2       2
Loopback0                 2        2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway Distance Last Update
192.168.12.1 120 00:15:43
Distance: (default is 120)

 

Все выглядит хорошо, вы можете видеть, что на R1 настроена цепочка ключей. Это означает, что R1 имеет аутентификацию.

Чтобы попробовать что-то еще, давайте включим отладку на этих маршрутизаторах:

 

R1 & R2 #debug ip rip
RIP protocol debugging is on

 

Вы увидите следующее:

 

R2#
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.2)
RIP: build update entries
2.2.2.0/24 via 0.0.0.0, metric 1, tag 0

 

R2 отправляет обновление, поэтому проблема, вероятно, связана с R1:

 

R1#
RIP: ignored v2 packet from 192.168.12.2 (invalid authentication)

 

R1 игнорирует обновление RIP из-за несоответствия аутентификации. RIP-аутентификация выполняется на интерфейсе, поэтому давайте проверим различия:

 

R1#show run interface FastEthernet 0/0
Building configuration...

Current configuration : 171 bytes
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain MY_CHAIN
duplex auto
speed auto
end
R2#show run interface FastEthernet 0/0
Building configuration...

Current configuration : 97 bytes
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
end

 

R1 имеет аутентификацию, а R2 — нет. Давайте исправим это:

 

R1(config)#interface FastEthernet 0/0
R1(config-if)#no ip rip authentication mode md5
R1(config-if)#no ip rip authentication key-chain MY_CHAIN

 

«Быстрое исправление» — это отключить аутентификацию. Это должно сработать:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:15, FastEthernet0/0

 

Задача решена! Извлеченный урок: убедитесь, что вы используете одни и те же параметры аутентификации с обеих сторон.

 

Ошибка фильтрации

Движемся дальше

 

r1-r2-loopback-behind-r2 - Устранение неполадок в RIP

 

Все те же маршрутизаторы, R1 не видит префикса 2.2.2.0/24:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

 

Show ip protocols — это хорошее место для начала проверки:

 

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
FastEthernet0/0 filtered by 1 (per-user), default is not set
Sending updates every 30 seconds, next due in 26 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                  Send Recv Triggered RIP Key-chain
FastEthernet0/0          2       2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.12.0
Routing Information Sources:
Gateway              Distance     Last Update
192.168.12.2            120 00:01:16
Distance: (default is 120)

 

R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface                  Send Recv Triggered RIP Key-chain
FastEthernet0/0         2       2
Loopback0                2        2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
192.168.12.0
Routing Information Sources:
Gateway           Distance      Last Update
192.168.12.1       120              00:24:34
Distance: (default is 120)

 

Внимательно посмотрите на R1. Вы можете увидеть, что есть фильтр на интерфейсе FastEthernet 0/0. Позвольте мне показать вам, как выглядит конфигурация R1:

 

R1#show run | section rip
router rip
version 2
network 192.168.12.0
distribute-list 1 in FastEthernet0/0
no auto-summary

 

Я добавил список distribute-list, который использует входящий список контроля доступа с номером 1. Вот как он выглядит:

 

R1#show access-lists 1
Standard IP access list 1
10 deny any (10 matches)

 

R1 не будет предоставлять никаких обновлений RIP. Мы можем удалить или отредактировать список доступа:

 

R1(config)#ip access-list standard 1
R1(config-std-nacl)#1 permit 2.2.2.0 0.0.0.255

 

Это должно помочь.

 

R1#show access-lists 1
Standard IP access list 1
1 permit 2.2.2.0, wildcard bits 0.0.0.255 (1 match)
10 deny any (12 matches)

 

Вы можете видеть, что теперь у нас есть попадание в разрешающую запись списка контроля доступа (match), давайте посмотрим, есть ли сеть в таблице маршрутизации:

 

R1#show ip route rip | begin Gateway
Gateway of last resort is not set

2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.12.2, 00:00:19, FastEthernet0/0

 

Вот оно! Извлеченный урок: убедитесь, что нет входящих или исходящих фильтров, которые предотвращают рассылку или прием обновлений RIP.

 

Проблема с расщеплением горизонта

На этот раз мы имеем другую топологию:

 

toplogy

 

У нас есть топология типа «звезда» с 3-мя маршрутизаторами. У двух удаленных (spoke) маршрутизаторов есть интерфейс обратной петли (loopback). Проблема в том, что оба эти маршрутизатора не знают в сетях друг друга:

 

Spoke1#show ip route rip

 

Spoke2#show ip route rip

 

Было бы неплохо проверить вывод команды show ip protocols, чтобы посмотреть объявление сетей. Топология «звезда «Frame Relay должна работать, хотя… разделение горизонта может быть проблемой. Посмотрим, узнал ли маршрутизатор Hub что-нибудь:

 

Hub#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 192.168.123.2, 00:00:25, Serial1/0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/1] via 192.168.123.3, 00:00:08, Serial1/0

 

Hub получил сети. Проблема в расщепленном горизонте?

 

Hub#show ip interface Serial 1/0 | include Split
Split horizon is enabled

 

Конечно, давайте избавимся от этого!

 

Hub(config)#interface Serial 1/0
Hub(config-if)#no ip split-horizon

 

Решили ли мы проблему?

 

Spoke2#show ip route rip
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/2] via 192.168.123.2, 00:00:01, Serial1/0

 

Spoke1#show ip route rip
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/2] via 192.168.123.3, 00:00:11, Serial1/0

 

Несомненно, маршрутизаторы узнали о сети друг друга. Имейте в виду, что расщепление горизонта отключено по умолчанию на физических последовательных интерфейсах. Извлеченный урок: убедитесь, что расщепленный горизонт не включен в топологии «звезда».

 

Проблема суммировния в RIP

Вот последняя проблема RIP, о которой я бы хотел вам рассказать:

 

topology - Устранение неполадок в RIP

R2 знает о сетях 172.16.1.0/24 и 172.16.3.0/24, но иногда пакеты не доходят до места назначения. Поскольку R2 действительно знает, как достичь этих сетей, лучше всего взглянуть на таблицу маршрутизации:

 

R2#show ip route rip
R 172.16.0.0/16 [120/1] via 192.168.23.3, 00:00:13, FastEthernet0/1
[120/1] via 192.168.12.1, 00:00:15, FastEthernet0/0

 

R2 видит одну запись для 172.16.0.0/16 и считает, что он может достичь этой сети через 192.168.23.3 или через 192.168.12.1. Проблема тут заключается в том, что подсетисети 172.16.x.0 /24 были суммированы до классовой сети 172.16.0.0/16. Кажется, что RIP ведет себя классово, а не бесскласово. Давайте проверим это:

 

R1#show ip protocols | include summ
Automatic network summarization is in effect

 

R3#show ip protocols | include summ
Automatic network summarization is in effect

 

R1 и R3 настроены для автоматического суммирования. Отключите его:

 

R1(config)#router rip
R1(config-router)#no auto-summary

 

R3(config)#router rip
R3(config-router)#no auto-summary

 

Теперь взгляните на таблицу маршрутизации R2:

 

R2#show ip route rip
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 192.168.12.1, 00:00:00, FastEthernet0/0
R 172.16.3.0 [120/1] via 192.168.23.3, 00:00:00, FastEthernet0/1

 

R1 и R3 теперь объявляют свои сети с правильной маской подсети, поэтому R2 знает, куда отправлять свои пакеты.

Извлеченный урок: в случае несмежных сетей включите RIPv2 и отключите автоматическое суммирование.

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University.

 

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню