EIGRP into RIP

Как настроить перераспределение между EIGRP и RIP

RIP

В прошлой статье я показал, как настроить перераспределение между доменами маршрутизации OSPF и RIP. На этот раз мы рассмотрим перераспределение между EIGRP и RIP. Вот исследуемая топология:

 

eigrp-rip-redistribution-r1-r2-r3

 

Маршрутизаторы R1 и R2 сконфигурированы для EIGRP. R2 и R3 оба настроены для RIP.

Сначала мы настроим EIGRP и RIP без какого-либо перераспределения:

 

R1(config)#router eigrp 12
R1(config-router)#no auto-summary
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 192.168.12.0

 

R2(config)#router eigrp 12
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0

 

R2(config)#router rip
R2(config-router)#no auto-summary
R2(config-router)#version 2
R2(config-router)#network 192.168.23.0

 

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.23.0
R3(config-router)#network 3.3.3.0

 

Выше приведены базовые настройки маршрутизации.
Перераспределение не происходит автоматически, что нужно настроить его вручную. Давайте это сделаем:

 

R2 (config) #router eigrp 12
R2 (config-router) #redistribute rip metric 1500 100 255 1 1500

 

Я перераспределяю RIP в EIGRP, и я должен указать метрики при этом. Выберите любые значения, которые вам нравятся. Если не указать начальную метрику, то она будет равна бесконечности (это метрика по умолчанию), и перераспределенные маршруты не будут отображаться!

 

R2(config)#router eigrp 12
R2(config-router)#default-metric 1500 100 255 1 1500

 

Вы также можете настроить начальную метрику (seed metric) глобально для EIGRP с помощью команды default-metric.

 

R1 # show ip route eigrp
3.0.0.0/24 subnetted, 1 subnets
D EX 3.3.3.0 [170/1734656] via 192.168.12.2, 00:01:39, FastEthernet0/0
D EX 192.168.23.0/24 [170/1734656] via 192.168.12.2, 00:03:49, FastEthernet0/0

 

Вот как выглядит таблица маршрутизации  R1. Вы можете увидеть, что эти сети отображаются как внешние сети EIGRP, а административное расстояние — 170.

 

R2 (config) #router rip
R2 (config-router) #redistribute eigrp 12 metric 10

 

Чтобы перераспределить EIGRP в RIP, нам нужно будет указать номер AS для EIGRP (12) и метрику (количество переходов).

 

R3 # show ip route rip
R 192.168.12.0/24 [120/10] via 192.168.23.2, 00:00:06, FastEthernet0/0
1.0.0.0/24 subnetted, 1 subnets
R 1.1.1.0 [120/10] via 192.168.23.2, 00:00:06, FastEthernet0/0

 

И здесь вы видите сводные настройки каждого маршрутизатора:

R1 R2 R3
Настройки каждого устройства hostname R1
!
interface Loopback 0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
router eigrp 12
no auto-summary
network 1.1.1.0 0.0.0.255
network 192.168.12.0
!
end
hostname R2
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
!
router eigrp 12
no auto-summary
network 192.168.12.0
redistribute rip metric 1500 100 255 1 1500
default-metric 1500 100 255 1 1500
!
router rip
no auto-summary
version 2
network 192.168.23.0
redistribute eigrp 12 metric 10
!
end
hostname R3
!
interface Loopback 0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
!
router rip
no auto-summary
version 2
network 192.168.23.0
network 3.3.3.0
!
end

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University.

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

Устранение неполадок в RIP

170
0
В этой статье мы продолжим разбирать RIP, старый протокол маршрутизации, который использует количество переходов в качестве своей метрики. В отличие…

Немного о команде offset-list

121
0
При запуске протокола маршрутизации, такого как EIGRP или OSPF, вы можете влиять на метрику протокола маршрутизации, изменяя пропускную способность bandwidth…
TTL

Объяснение TTL в пакетах EIGRP и RIP

149
0
Если вы когда-либо просматривали захват пакетов EIGRP или RIP, вы могли заметить, что значение TTL (время жизни) равно 2. Вероятно,…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Most Viewed Posts

Все о команде PING

1,555
0
Все системные администраторы и ИТ-специалисты хорошо знакомы с командой ping. Это команда для проверки базовой связи между двумя хостами, такими…
Меню