Немного о команде offset-list

Немного о команде offset-list

RIP

При запуске протокола маршрутизации, такого как EIGRP или OSPF, вы можете влиять на метрику протокола маршрутизации, изменяя пропускную способность bandwidth (OSPF или EIGRP) или изменяя задержку delay (EIGRP). RIP использует количество переходов, поэтому вам нужно добавить несколько дополнительных маршрутизаторов, чтобы увеличить количество переходов. Вместо изменения параметров, влияющих на маршрутизацию, вы можете использовать список смещений (offset-list).

Список смещений позволяет увеличить метрику при получении или отправке обновления маршрутизации на смежный маршрутизатор. Вы можете использовать его для RIP или EIGRP, но он не поддерживается для OSPF.

Для лучшего понимания, покажу вам на примере:

 

r1-r2-cisco-rip

 

У нас есть два маршрутизатора RIP с версией 2. Маршрутизатор слева (R1) имеет два интерфейса loopback, которые были объявлены в RIP. Вот как выглядит таблица маршрутизации R2:

 

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 192.168.12.1, 00:00:17, FastEthernet0/0
11.0.0.0/24 is subnetted, 1 subnets
R 11.11.11.0 [120/1] via 192.168.12.1, 00:00:17, FastEthernet0/0

 

Здесь нет ничего особенного, мы видим два префикса с количеством переходов, равным 1. Давайте увеличим количество переходов для первого префикса, используя исходящий список смещений на R1:

 

R1(config)#router rip
R1(config-router)#offset-list ?
<0-99> Access list of networks to apply offset (0 selects all networks)
<1300-1999> Access list of networks to apply offset (expanded range)
WORD Access-list name

 

Вам необходимо сделать настройки протокола маршрутизации и использовать команду offset-list. Я могу выбирать между всеми сетями или использовать стандартный список контроля доступа, чтобы выбрать какую-то сеть. Давайте используем ACL:

 

R1(config-router)#offset-list 1 ?
in Perform offset on incoming updates
out Perform offset on outgoing updates

 

Когда вы выбираете список контроля доступа, вам нужно определить тип вашего списка смещения, входящий он или исходящий. Я буду использовать исходящий, чтоб R2 получал большее количество переходов с R1. Последняя опция позволяет вам выставлять метрику:

 

R1(config-router)#offset-list 1 out ?
<0-16> Offset

 

Когда используем RIP, у нас нет большого выбора. Давайте попробуем сделать счетчик переходов равным 5:

 

R1(config-router)#offset-list 1 out 5

 

И последнее, но не менее важное: не забудьте создать список контроля доступа, иначе список смещений будет применяться ко всем префиксам:

 

R1 (config) # access-list 1 permit 1.1.1.0 0.0.0.255

 

Вот результат:

 

R2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/6] via 192.168.12.1, 00:00:17, FastEthernet0/0
11.0.0.0/24 is subnetted, 1 subnets
R 11.11.11.0 [120/1] via 192.168.12.1, 00:00:17, FastEthernet0/0

 

Вы можете увидеть, что префикс 1.1.1.0 /24 имеет увеличенное на 5 количество переходов, теперь в конечном итоге равеное 6.

Вы увидели исходящий список смещений, давайте попробуем входящий. Я создам список доступа на R2, который увеличивает количество переходов префикса 11.11.11.0 /24:

 

R2(config)#access-list 2 permit 11.11.11.0 0.0.0.255

 

Это был список контроля доступа, а вот список смещений:

 

R2(config-router)#offset-list 2 in 10

 

Он должен увеличить количество переходов для префикса 11.11.11.0 на 10, как только R2 узнает об этом префиксе. Вот таблица маршрутизации R2:

 

R2#show ip route rip
*Aug 21 12:48:19.211: %SYS-5-CONFIG_I: Configured from console by console
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/6] via 192.168.12.1, 00:00:26, FastEthernet0/0
11.0.0.0/24 is subnetted, 1 subnets
R 11.11.11.0 [120/11] via 192.168.12.1, 00:00:26, FastEthernet0/0

 

Вы можете увидеть, что общее количество переходов теперь равно 11.

Еще одна маленькая вещь, которую я хотел бы рассказать о списке смещения. По умолчанию список смещений будет применяться ко всем интерфейсам. Если вы хотите влиять только на метрику обновлений маршрутизации c определенного интерфейса, тогда вам нужно сделать так:

 

R2(config-router)#offset-list 2 in 10 ?
Async        Async interface
Auto-Template Auto-Template interface
BVI Bridge-Group Virtual Interface
CDMA-Ix CDMA Ix interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
[output omitted]

 

Когда вы настраиваете список смещения, вы можете указать интерфейс после метрики:

 

R2(config-router)#offset-list 2 in 10 FastEthernet 0/0

 

Это говорит маршрутизатору увеличивать только метрику для обновлений маршрутизации, которые он получает через интерфейс FastEthernet 0/0.

 

R1 R2
Сводные настройки маршрутизаторов hostname R1
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Loopback2
ip address 11.11.11.11 255.255.255.0
!
router rip
offset-list 1 out 5
!
access-list 1 permit 1.1.1.0 0.0.0.255
!
end
hostname R2
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
router rip
offset-list 2 in 10
offset-list 2 in 10 FastEthernet 0/0
!
access-list 2 permit 11.11.11.0 0.0.0.255
!
end

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University.

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
RIP

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню