Базовая настройка коммутатора

Базовая настройка коммутатора Cisco Catalyst

Новости

В этой статье я хочу вас познакомить с настройками, с которыми сталкивается любой сетевой инженер, это базовые настройки устройства. Более конкретно рассмотрим базовую настройку коммутатора Cisco Catalyst. В моем примере это Cisco Catalyst 2950, однако базовые настройки для коммутаторов различных платформ одинаковы.

Собираем топологию, как на рисунке.

blog-switch-pc-topology

Для этого нам понадобится rollover-консольный кабель. Подключаем один конец rollover-консольного кабеля к консольному порту RJ-45 на коммутаторе. Другой конец кабеля подключаем к последовательному COM-порту на компьютере. Если на компьютере отсутствует последовательный COM-порт, то вам понадобиться USB–Serial (DB9) переходник. При использовании USB–Serial (DB9) переходника для подключения rollover-консольного кабеля может потребоваться установка драйвера. Его можно скачать с сайта производителя USB–Serial (DB9) переходника. Также нам понадобится знать номер COM-порта для того, чтобы выполнить подключение, его можно посмотреть через Диспетчер устройств после подключения переходника.

Базовая настройка коммутатора Cisco Catalyst

Самый лучший переходник USB–Serial (DB9), которым мне довелось пользоваться, это PL2303 фирмы Prolific Technology Inc. Для этого переходника доступны драйвера для всех популярных операционных систем.

Базовая настройка коммутатора Cisco Catalyst

Запускаем программу эмуляции терминала — PuTTy. Указываем номер COM-порта, указываем настройки подключения как на рисунке и нажимаем на кнопку Open.

putty-serial-config

Также необходимо соединить компьютер обычным прямым (straight-through) патч-кордом с портом FastEthernet 0/1 коммутатора, как показано на рисунке.

Итак начнем, включаем питание. Устройство выполняет Power-On-Self-Test (POST) — самотестирование, после чего идет загрузка операционной системы Cisco IOS. В моем случае устройство сброшено к заводским настройкам и на нем нет файла начальной конфигурации (startup-config). При загрузке вы должны увидеть что-то такое:

C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(14)AZ, RELEASE SOFTWARE (fc2)
Compiled Tue 14-Oct-03 17:14 by antonino
WS-C2950T-48-SI starting...
Base ethernet MAC Address: 00:15:63:68:c7:40
Xmodem file system is available.
Initializing Flash...
flashfs[0]: 327 files, 5 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 5649920
flashfs[0]: Bytes available: 2091520
flashfs[0]: flashfs fsck took 7 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading "flash:/c2950-i6k2l2q4-mz.121-22.EA14.bin"...###############################################################################################################################################################################################################################

File "flash:/c2950-i6k2l2q4-mz.121-22.EA14.bin" uncompressed and installed, entry point: 0x80010000
executing...

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra
Image text-base: 0x80010000, data-base: 0x80680000

Initializing flashfs...
flashfs[1]: 327 files, 5 directories
flashfs[1]: 0 orphaned files, 0 orphaned directories
flashfs[1]: Total bytes: 7741440
flashfs[1]: Bytes used: 5649920
flashfs[1]: Bytes available: 2091520
flashfs[1]: flashfs fsck took 7 seconds.
flashfs[1]: Initialization complete.
Done initializing flashfs.
POST: System Board Test : Passed
POST: Ethernet Controller Test : Passed
ASIC Initialization Passed

POST: FRONT-END LOOPBACK TEST : Passed
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected]

cisco WS-C2950T-48-SI (RC32300) processor (revision G0) with 19911K bytes of memory.
Processor board ID FHK0937X0UQ
Last reset from system-reset
Running Standard Image
48 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:15:63:68:C7:40
Motherboard assembly number: 73-9102-04
Power supply part number: 34-0965-01
Motherboard serial number: FOC093717VY
Power supply serial number: DAB0934EE5X
Model revision number: G0
Motherboard revision number: A0
Model number: WS-C2950T-48-SI
System serial number: FHK0937X0UQ
CLEI Code Number: CNMRU002RC
Top Assembly Part Number: 800-24111-03
Top Assembly Revision Number: A0
Version ID: N/A

--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:
00:00:19: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
00:00:23: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA14, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by cisco Systems, Inc.
Compiled Tue 26-Oct-10 10:35 by nburra
00:00:23: %SNMP-5-COLDSTART: SNMP agent on host Switch is undergoing a cold start
00:00:27: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:00:27: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
00:00:28: %LINK-3-UPDOWN: Interface FastEthernet0/48, changed state to up
00:00:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
00:00:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
00:00:30: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/48, changed state to up
00:00:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

 

Если загрузка прошла штатно, то вы должны увидеть приглашение в конфигурационный диалог, мы здесь отвечаем no, потому что будем сами все настраивать.

% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? [yes/no]:  no

Press RETURN to get started!

Switch>

 

Собственно после этого мы попадаем в командную строку, где и будем выполнять базовую настройку.

Далее нужно убедиться в том, что коммутатор действительно сброшен к заводским настройкам:

Switch>enable
Switch#show startup-config
startup-config is not present
Switch#

 

Изначально мы попадаем в пользовательский режим user EXEC. Он имеет ограниченные возможности. Этот режим выглядит таким образом:

Switch>

 

Переключаемся в привилегированный режим privileged EXEC, для этого нужно ввести команду:

Switch>enable
Switch#

 

Переключаемся в режим глобальной конфигурации, для этого вводим команду:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#

 

Необходимо задать имя устройству:

Switch(config)#hostname switch-floor-1
switch-floor-1(config)#

Здесь мы указали имя коммутатору switch-floor-1. Рекомендую задавать имя для устройства логично, чтобы потом не перепутать и было через время очевидно, что это за устройство и где оно находится.

 

Обязательно задаем пароль на привилегированный EXEC режим:

switch-floor-1(config)#enable secret class
switch-floor-1(config)#

 

Запрещаем нежелательный поиск в DNS:

switch-floor-1(config)#no ip domain-lookup
switch-floor-1(config)#

 

Задаем баннероное сообщение MOTD, которое будет выводиться перед входом в систему:

switch-floor-1(config)#banner motd #
Enter TEXT message.  End with the character '#'.
Unauthorized access is strictly prohibited.#
switch-floor-1(config)#

Обратите внимание, что здесь открывающий символ для сообщения это # (решетка), соответственно нужно обязательно баннерное сообщение заканчивать этим знаком # (решетка).

 

Проверяем настройки доступа. Для этого переключаемся между режимами:

switch-floor-1(config)#exit
switch-floor-1#exit
01:19:48: %SYS-5-CONFIG_I: Configured from console by consoleexit

switch-floor-1 con0 is now available

Press RETURN to get started.

Unauthorized access is strictly prohibited.
switch-floor-1>en
Password:class
switch-floor-1#

Примечание. Пароль не будет отображаться на экране во время ввода.

 

Обеспечим возможность удаленного управления коммутатором, для этого необходимо настроить IP-адрес на Switch Virtual Interface (SVI). Перейдем в режим глобальной конфигурации и далее в SVI:

switch-floor-1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch-floor-1(config)#interface vlan1  1
switch-floor-1(config-if)#ip address 192.168.1.2 255.255.255.0
switch-floor-1(config-if)#no shutdown
switch-floor-1(config-if)#exit
03:21:33: %LINK-3-UPDOWN: Interface Vlan1, changed state to up
03:21:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
switch-floor-1(config)#

 

Ограничим доступ к консольному порту. Конфигурация по умолчанию разрешает все консольные подключения без пароля:

switch-floor-1(config)#line console 0
switch-floor-1(config-line)#password cisco
switch-floor-1(config-line)#login
switch-floor-1(config-line)#exit
switch-floor-1(config)#

 

Настроим линии Virtual Teletype (VTY) для коммутатора, чтобы разрешить удаленный доступ по протоколу Telnet. Если вы не настроите пароль VTY, то не сможете обращаться к коммутатору по протоколу Telnet:
switch-floor-1(config)#line vty 0 4
switch-floor-1(config-line)#password cisco
switch-floor-1(config-line)#login
switch-floor-1(config-line)#end
switch-floor-1#
03:28:46: %SYS-5-CONFIG_I: Configured from console by console

Здесь мы задаем пароль для пяти одновременных подключений, в Cisco IOS диапазон указывается через пробел.

 

Далее настроим IP-адрес на компьютере:

Выберите Просмотр состояния сети и задач > Изменение параметров адаптера
Правой кнопкой мыши щелкните Подключение по локальной сети и выберите Свойства
Выберите Протокол Интернета версии 4 (TCP/IPv4), затем Свойства вводим IP-адрес 192.168.1.10 и нажмите OK 

 

Должно получиться как-то так:

Базовая настройка коммутатора Cisco Catalyst

 

Теперь посмотрим настройки коммутатора:

switch-floor-1#show running-config
Building configuration...

Current configuration : 2094 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname switch-floor-1
!
enable secret 5 $1$8NIH$TK/0Mc5cBcDQ20tshY0dS.
!
ip subnet-zero
!
no ip domain-lookup
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
no ip route-cache
!
ip http server
banner motd ^C
Unauthorized access is strictly prohibited.^C
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
login
!
!
end

switch-floor-1#

 

Проверяем состояние интерфейса управления SVI. Состояние интерфейса VLAN 1 должно быть up/up, что указывает на то, что он активен, и ему должен быть назначен IP-адрес. Обратите внимание, что состояние порта коммутатора FastEthernet0/1 — тоже up, так как к нему подключен компьютер. Поскольку все порты коммутатора изначально принадлежат VLAN 1 по умолчанию, вы можете взаимодействовать с коммутатором по IP-адресу, который был назначен для VLAN 1.

switch-floor-1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.1.2     YES manual up                    up
FastEthernet0/1            unassigned      YES unset  up                    up
FastEthernet0/2            unassigned      YES unset  down                  down
FastEthernet0/3            unassigned      YES unset  down                  down
FastEthernet0/4            unassigned      YES unset  down                  down
FastEthernet0/5            unassigned      YES unset  down                  down
FastEthernet0/6            unassigned      YES unset  down                  down
FastEthernet0/7            unassigned      YES unset  down                  down
FastEthernet0/8            unassigned      YES unset  down                  down
FastEthernet0/9            unassigned      YES unset  down                  down
FastEthernet0/10           unassigned      YES unset  down                  down
FastEthernet0/11           unassigned      YES unset  down                  down
FastEthernet0/12           unassigned      YES unset  down                  down
FastEthernet0/13           unassigned      YES unset  down                  down
FastEthernet0/14           unassigned      YES unset  down                  down
FastEthernet0/15           unassigned      YES unset  down                  down
FastEthernet0/16           unassigned      YES unset  down                  down
FastEthernet0/17           unassigned      YES unset  down                  down
FastEthernet0/18           unassigned      YES unset  down                  down
FastEthernet0/19           unassigned      YES unset  down                  down
FastEthernet0/20           unassigned      YES unset  down                  down
FastEthernet0/21           unassigned      YES unset  down                  down
FastEthernet0/22           unassigned      YES unset  down                  down
FastEthernet0/23           unassigned      YES unset  down                  down
FastEthernet0/24           unassigned      YES unset  down                  down
FastEthernet0/25           unassigned      YES unset  down                  down
FastEthernet0/26           unassigned      YES unset  down                  down
FastEthernet0/27           unassigned      YES unset  down                  down
FastEthernet0/28           unassigned      YES unset  down                  down
FastEthernet0/29           unassigned      YES unset  down                  down
FastEthernet0/30           unassigned      YES unset  down                  down
FastEthernet0/31           unassigned      YES unset  down                  down
FastEthernet0/32           unassigned      YES unset  down                  down
FastEthernet0/33           unassigned      YES unset  down                  down
FastEthernet0/34           unassigned      YES unset  down                  down
FastEthernet0/35           unassigned      YES unset  down                  down
FastEthernet0/36           unassigned      YES unset  down                  down
FastEthernet0/37           unassigned      YES unset  down                  down
FastEthernet0/38           unassigned      YES unset  down                  down
FastEthernet0/39           unassigned      YES unset  down                  down
FastEthernet0/40           unassigned      YES unset  down                  down
FastEthernet0/41           unassigned      YES unset  down                  down
FastEthernet0/42           unassigned      YES unset  down                  down
FastEthernet0/43           unassigned      YES unset  down                  down
FastEthernet0/44           unassigned      YES unset  down                  down
FastEthernet0/45           unassigned      YES unset  down                  down
FastEthernet0/46           unassigned      YES unset  down                  down
FastEthernet0/47           unassigned      YES unset  down                  down
FastEthernet0/48           unassigned      YES unset  down                  down
GigabitEthernet0/1         unassigned      YES unset  down                  down
GigabitEthernet0/2         unassigned      YES unset  down                  down
switch-floor-1#

 

Протестируем подключение между компьютером и коммутатором. Открываем окно командной строки (cmd.exe) на компьютере. В командной строке пишем команду ipconfig для того, чтобы посмотерть сведения об IP-адресе.

windows-ipconfig

Там же в командной строке вводим команду ping, которая используется для проверки подключения.

windows-ping

Обратите внимание, что первый тест прошел неудачно, мы видим сообщение Request timed out. Это связано с тем, что отработал протокол ARP, который используется для получения неизвестного MAC-адреса получателя по известному IP-адресу. Второй тест прошел успешно, поскольку MAC-адрес получателя уже был в ARP-кеше компьютера.

Теперь проверим удаленное подлючение с компьютера на коммутатор через сеть с помощью Telnet. Для этого на комьютере запустим PuTTy и в строке Host Name (or IP address) вводим IP-адрес 192.168.1.2, который был назначен на VLAN 1 коммутатора. Выбираем протокол Telnet для подключения, оставляем порт 23 по умолчанию и нажимаем Open.

windows-putty-telnet

windows-putty-telnet-work

Ну что ж, осталось сохранить настройки коммутатора:

switch-floor-1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
switch-floor-1#

 

А если вам необходимо наоборот удалить сохраненные настройки и сбросить настройки коммутатора к заводским, то воспользуйтесь следующими командами:

switch-floor-1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
switch-floor-1#
06:48:31: %SYS-7-NV_BLOCK_INIT: Initalized the geometry of nvramreload      
switch-floor-1#reload
Proceed with reload? [confirm]

06:48:46: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

 

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, регистрируйтесь на курсы Cisco и Linux Professional Institute на платформе SEDICOMM University.

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

4 комментария. Оставить новый

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое

Результатов не найдено.

Меню