Как настроить Интернет на коммутаторе / маршрутизаторе Cisco для небольшой офисной сети

Как настроить Интернет на коммутаторе / маршрутизаторе Cisco для небольшой офисной сети

Рассмотрим, как настроить Интернет на коммутаторе / маршрутизаторе Cisco для небольшой офисной сети. Самыми необходимыми для нормальной работы сети офиса являются настройки маршрутизации, коммутации, IP-адресации DHCP, трансляции сетевых адресов NAT (IP Masquerade), проброса (перенаправления) портов (port forwarding).

Исследуемая топология состоит из одного коммутатора Cisco Catalyst 2960 с операционной системой Cisco WS-C2960-24TT-L с ОС Cisco IOS Release 15.0(2)SE4 (образ C2960-LANBASEK9-M) и одного маршрутизатора Cisco 2911 с операционной системой Cisco IOS версии 15.6(3)M2 (образ C2900-UNIVERSALK9-M)). Допускается использование других коммутаторов и версий Cisco IOS.

 

Схема топологии следующая:

 

Как настроить Интернет на коммутаторе / маршрутизаторе Cisco для небольшой офисной сети

 

Сценарий

В небольшой офисной сети (Small Office Home Office, SOHO) есть локальная сеть (частная сеть) и выход в Интернет через одного провайдера. В локальной сети находится сервер, который должен быть доступен из публичной сети. Нужно настроить все самые необходимые службы для того чтобы у пользователей сети был доступ в Интернет, а у пользователей из Интернета был доступ к серверу, который находится в локальной сети (имеет частный адрес).

 

Задачи

Часть 1. Построение сети и проверка соединения
Часть 2. Настройка базовых параметров коммутатора и маршрутизатора
Часть 3. Настройка сервисов (маршрутизации, коммутации, IP-адресации DHCP, трансляции сетевых адресов NAT (IP Masquerade), проброса (перенаправления) портов (port forwarding))

 

Конфигурации базовых параметров коммутатора и маршрутизатора после выполнения Части 2

 

hostname R1 [S1] 
no ip domain-lookup
enable secret class
line console 0
logging synchronous
exec-timeout 0 0
password cisco
login
exit
banner motd #Authorized Access Only#
service password encryption
copy running-config startup-config

 

Настройка подключения по SSH:

ip domain name span.com
crypto key generate rsa general-keys modulus 1024
username admin secret cisco
line vty 0 4
login local
transport input ssh
exit 

 

Конфигурации маршрутизатора после выполнения Части 3

 

Настроим адресацию на интерфейсах маршрутизатора:

interface gi0/0
ip address dhcp
no shutdown
exit
interface gi0/1
ip address 192.168.1.1 255.255.255.0
no shutdown
exit

 

Настроим NAT на маршрутизаторе:

access-list 1 permit 192.168.1.0 0.0.0.255 
ip nat inside source list 1 interface gi0/0 overload
interface gi0/0 
ip nat outside
exit 
interface gi0/1 
ip nat inside
exit

 

На современных IOSах доступны настройки новой функции — виртуального интерфейса NAT (NAT virtual interface, NVI), — которая устраняет необходимость настройки интерфейса как внутреннего, так и внешнего.

На одном из компьютеров во внутренней сети развернут веб-сервер и ему присвоен статический адрес.

Для того, чтобы http-запросы проходили из внешней сети на веб-сервер, необходимо на маршрутизаторе R1 сделать следующие настройки:

ip nat inside source static tcp 192.168.1.3 80 interface GigabitEthernet0/0 80

 

Настроим службу DHCP для внутренней сети:

ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp pool LAN-DHCP
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
exit 
Конфигурации коммутатора после выполнения Части 3
interface vlan 1
ip address 192.168.1.2 255.255.255.0
no shutdown
exit
ip default-gateway 192.168.1.1
exit
Проверка настроек

 

show running-config
show ip interface brief
show ip nat translations
show ip nat translations verbose
show ip nat statistics
show ip dhcp binding 
show ip dhcp server statistics

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Cisco

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню