Рассмотрим как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе Cisco.

Как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе

Cisco

Рассмотрим как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе Cisco. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

Рассмотрим как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе Cisco.

 

Сценарий

Одна из основных проблем, с которой сталкиваются компании, это отказоустойчивость сетей. Отказоустойчивость достигается за счет резервирования (устройств, каналов связи, сервисов и т.д.). Одно из основных направлений, где реализуется резервирование (Floating route), — это наличие подключения к нескольким интернет-провайдерам по схеме Dual-homed или Multihomed. При этом важно, чтобы переключение между провайдерами осуществлялось автоматически в случае сбоя основного маршрута.

Еще одна интересная задача, которая может возникать в современных сетях, это обеспечение мониторинга уровня качества обслуживания QoS предоставляемых сервисов. Для выполнения этой задачи можно настроить технологию IP SLA, которая рассматривалась в нашей статье.

 

Задачи

Часть 1. Построение сети и проверка подключения
Часть 2. Настройка маршрутизации на маршрутизаторах
Часть 3. Настройка IP SLA ICMP Echo на Edge

 

Конфигурации Edge после выполнения Части 2
hostname Edge
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface Gi 0/2
ip address 192.168.1.1 255.255.255.0
no shut
exit

interface Gi 0/0
ip address 192.168.2.1 255.255.255.0
no shut
exit

ip route 0.0.0.0 0.0.0.0 Gi0/2

ip route 0.0.0.0 0.0.0.0 Gi0/0 10
Конфигурации ISP1 после выполнения Части 2
hostname ISP1
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface Gi 0/0
ip address 192.168.1.2 255.255.255.0
no shut
exit

interface Gi 0/2
ip address 192.168.3.1 255.255.255.0
no shut
exit

ip route 192.168.3.0 255.255.255.0 Gi0/0
Конфигурации ISP2 после выполнения Части 1
hostname ISP2
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

interface Gi 0/0
ip address 192.168.3.2 255.255.255.0
no shut
exit

interface Gi 0/2
ip address 192.168.2.2 255.255.255.0
no shut
exit

ip route 192.168.3.0 255.255.255.0 Gi0/2

 

 

Конфигурации Edge после выполнения Части 3
ip sla 22
icmp-echo 192.168.3.1
frequency 10

ip sla schedule 22 start-time now life forever

track 1 ip sla 22 reachability

ip route 0.0.0.0 0.0.0.0 Gi0/2 track 1

 

 

Проверка и тестирование выполнения операции IP SLA
show track

show ip sla configuration

show ip sla statistics

Нам теперь осталось проверить как будет реагировать маршрутизатор на изменения в сети.

 

Спасибо за уделенное время на прочтение статьи о том, как использовать технологию Cisco IP SLA для оценки качества и мониторинга сети и резервирования маршрутов (Floating route)!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Cisco

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню