Как настроить виртуализацию маршрутизации VRF Lite на маршрутизаторе Cisco

Cisco

Рассмотрим как настроить на Cisco виртуальные маршрутизаторы для реализации сегментации (изолирования) процессов маршрутизации и других задач (NAT, DHCP и т.д.) с помощью технологии VRF Lite (Virtual Routing and Forwarding). Исследуемая топология состоит из маршрутизатора Cisco 2911 с ПО Cisco IOS версии 15 и коммутатора Cisco Catalyst 2960 под управлением Cisco IOS 15.0(2)SE6. Допускается использование других маршрутизаторов/коммутаторов и версий Cisco IOS.

 

Схема топологии следующая:

Как настроить виртуализацию маршрутизации VRF Lite на маршрутизаторе Cisco

 

Сценарий

VRF — это технология, которая поддерживает несколько экземпляров (процессов) маршрутизации внутри одного маршрутизатора (или коммутатора уровня 3). Это означает, что один маршрутизатор может иметь несколько отдельных таблиц маршрутизации, и каждая из них полностью независима. Благодаря своей независимости он также позволяет использовать перекрывающиеся IP-адреса. Маршрутизатор Cisco IOS по умолчанию поддерживает VRF. В этой статье будет показана настройка VRF Lite (версия VRF без MPLS) в маршрутизаторе Cisco IOS для установления соединения для двух локальных сетей с перекрывающимися адресными пространствами.
Есть еще и другие интересные задачи, которые можно реализовать в современных сетях, с помощью виртуализации маршрутизации (изолирование процессов маршрутизации, специфические настройки для отдельных сетей, например, DHCP, NAT и многое другое). Пример такой задачи можно посмотреть в нашей статье.

В этом сценарии у поставщика услуг ISP есть два клиента, а именно «Company A» и «Company B». ISP использует один маршрутизатор, который совместно используется компаниями «A» и «B». Интерфейс Gi0/1 на маршрутизаторе подключен к коммутатору, а коммутатор подключен к каждой сети компании.

Цель состоит в том, чтобы сеть компании «Company A» могла получить доступ к адресу Loopback1, а «Company B» должна иметь доступ к адресу Loopback2. Однако по какой-то причине обеим компаниям необходимо использовать один и тот же сетевой адрес, но они отказываются открывать доступ к своей сети друг другу. Поэтому используется отдельная сеть VLAN, где VLAN10 предназначена для «Company A», а VLAN20 — для «Company В».

 

Задачи

Часть 1. Построение сети и проверка подключения
Часть 2. Настройка процесса VRF
Часть 3. Настройка VRF на интерфейсах

 

Конфигурации ISP после выполнения Части 2
hostname ISP
no ip domain-lookup
line con 0
exec-timeout 0 0
logging synchronous

ip vrf Company-A
exit
ip vrf Company-B
exit

 

 

Конфигурации ISP после выполнения Части 3
interface Gi 0/1
no shut
exit

interface Gi 0/1.10
description Connection-to-Company-A
encapsulation dot1q 10
ip vrf forwarding Company-A
ip address 10.10.10.1 255.255.255.0
exit

interface Gi 0/1.20
description Connection-to-Company-B
encapsulation dot1q 20
ip vrf forwarding Company-B
ip address 10.10.10.1 255.255.255.0
exit

interface Loopback 1
ip vrf forwarding Company-A
ip address 10.1.1.1 255.255.255.0
exit

interface Loopback 2
ip vrf forwarding Company-B
ip address 10.2.2.1 255.255.255.0
exit

 

 

Проверка и тестирование работы VRF Lite
show ip vrf
ping vrf Company-A 10.10.10.2
show ip route vrf

Нам теперь осталось проверить как будет проходить пинг с оконечных устройств.

 

Спасибо за уделенное время на прочтение статьи о том, как использовать технологию VRF Lite на Cisco!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Cisco

Больше похожих постов

Рассмотрим как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе Cisco.

Как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе

48
0
Рассмотрим как настроить резервирование маршрутов (Floating route) с динамическим переключением (IP SLA) на маршрутизаторе Cisco. Исследуемая топология состоит из трех…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню