VRF Lite на Cisco

Как настроить изолированные процессы маршрутизации с помощью VRF Lite на Cisco IOS

MPLS

В этой статье мы рассмотрим VRF Lite на Cisco (виртуальная маршрутизация и пересылка). По умолчанию маршрутизатор использует одну глобальную таблицу маршрутизации, которая содержит все непосредственно подключенные сети и префиксы, которые он получил через статические или динамические протоколы маршрутизации.

 

VRF подобно VLAN маршрутизаторам, как следствие вместо использования единой глобальной таблицы маршрутизации мы можем использовать несколько виртуальных таблиц маршрутизации. Каждому интерфейсу маршрутизатора присваивается разные VRF.

 

VRF обычно используются для развертываний MPLS, когда мы используем VRF без MPLS, тогда это называется VRF lite. На этом мы и остановимся, чтобы рассмотреть подробней. Давайте посмотрим на топологию приведенную ниже для примера:

ISP Router customer Red BlueIn thtopology:

 

 

В топологии на картинке выше у нас есть один маршрутизатор ISP и два клиента под названием «Red» и «Blue». Каждый клиент имеет две стороны и подключен к маршрутизатору ISP. Маршрутизатор ISP имеет только одну глобальную таблицу маршрутизации, поэтому, если мы подключаем все как на топологии выше, то таблица маршрутизации будет выглядеть:

ISP#show ip route connected
C 192.168.4.0/24 is directly connected, FastEthernet3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet1/0
C 192.168.3.0/24 is directly connected, FastEthernet2/0

 

 

Маршрутизатор ISP имеет одну глобальную таблицу маршрутизации, в которой есть все 4 сети с прямым подключением. Давайте использовать VRF, чтобы изменить это. Я хочу создать отдельную таблицу маршрутизации для клиентов «Red» и «Blue». Сначала мы должны создать VRF для этого:

ISP(config)#ip vrf Red
ISP(config-vrf)#exit
ISP(config)#ip vrf Blue
ISP(config-vrf)#exit

 

 

Глобально мы создаем VRF, по одному для каждого клиента. Следующий шаг — добавить интерфейсы маршрутизатора ISP к правильному VRF. Вот как это сделать:

ISP(config)#interface FastEthernet 0/0
ISP(config-if)#ip vrf forwarding Blue
% Interface FastEthernet0/0 IP address 192.168.1.254 removed due to enabling VRF Blue
ISP(config-if)#ip address 192.168.1.254 255.255.255.0

 

 

В режиме настройки интерфейса мы используем команду ip vrf forwarding, чтобы назначить интерфейс правильному VRF. Как только вы это сделаете, вам придется снова добавить IP-адрес. Давайте сконфигурируем остальные интерфейсы:

ISP(config)#interface FastEthernet 1/0
ISP(config-if)#ip vrf forwarding Red
ISP(config-if)#ip address 192.168.2.254 255.255.255.0

 

ISP(config)#interface FastEthernet 2/0
ISP(config-if)#ip vrf forwarding Blue
ISP(config-if)#ip address 192.168.3.254 255.255.255.0

 

ISP(config)#interface FastEthernet 3/0
ISP(config-if)#ip vrf forwarding Red
ISP(config-if)#ip address 192.168.4.254 255.255.255.0

 

 

Видим, что теперь все интерфейсы настроены. Есть полезная команда, которую вы можете использовать для просмотра всех VRF и их интерфейсов:

ISP#show ip vrf
Name Default RD Interfaces
Blue Fa0/0
Fa2/0
Red Fa1/0
Fa3/0

 

 

Наши VRF настроены, давайте посмотрим на глобальную таблицу маршрутизации маршрутизатора ISP:

ISP#show ip route connected

 

 

В глобальной таблице маршрутизации нет записей, это связано с тем, что все интерфейсы были добавлены в VRF. Давайте проверим таблицы маршрутизации VRF:

ISP#show ip route vrf Blue connected
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, FastEthernet2/0

 

ISP#show ip route vrf Red connected
C 192.168.4.0/24 is directly connected, FastEthernet3/0
C 192.168.2.0/24 is directly connected, FastEthernet1/0

 

 

Мы используем команду show ip route, но вам нужно указать, какой VRF вы хотите посмотреть. Как вы можете видеть, каждый VRF имеет свою собственную таблицу маршрутизации с интерфейсами, которые мы настроили ранее.

 

Если вы хотите что-то сделать на маршрутизаторе, например, отправить пинг, вам нужно будет указать, какой VRF вы хотите использовать. По умолчанию будет использоваться глобальная таблица маршрутизации. Ниже приведен пример того, как отправить пинг:

ISP#ping vrf Blue 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

 

Это достаточно просто, просто не забудьте указать правильный VRF. То же самое относится к маршрутизации (протоколов). Например, если вы хотите настроить статический маршрут, вам нужно будет указать правильный VRF. Взгляните на приведенный ниже пример:

VRF Static route loopback

 

 

Маршрутизатор Blue1 имеет интерфейс обратной петли с IP-адресом 1.1.1.1 / 32. Давайте создадим статический маршрут на маршрутизаторе ISP, чтобы мы могли его достичь:

ISP(config)#ip route vrf Blue 1.1.1.1 255.255.255.255 192.168.1.1

 

 

Мы используем ту же команду ip route, но я указал, что статический маршрут принадлежит VRF. Давайте посмотрим, работает ли это:

ISP#ping vrf Blue 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/52 ms

 

 

Достаточно легко, пинг работает. Как насчет протоколов маршрутизации? Мы можем использовать OSPF, EIGRP, BGP и другие, никаких проблем с этим нет. Давайте посмотрим на примере для протокола OSPF:

VRF Lite на Cisco

 

Клиент «Blue» и «Red» оба хотят использовать OSPF для своих сетей. Поскольку мы используем VRF, все разделено. Начнем с конфигурации OSPF для клиента Blue:

Blue1(config)#router ospf 1
Blue1(config-router)#network 192.168.1.0 0.0.0.255 area 0
Blue1(config-router)#network 1.1.1.1 0.0.0.0 area 0

 

Blue2(config)#router ospf 1
Blue2(config-router)#network 192.168.3.0 0.0.0.255 area 0
Blue2(config-router)#network 3.3.3.3 0.0.0.0 area 0

 

 

Конфигурация OSPF для маршрутизаторов клиентов довольно проста. На маршрутизаторе ISP нам нужно будет указать, какой VRF мы хотим использовать:

ISP(config)#router ospf 1 vrf Blue
ISP(config-router)#network 192.168.1.0 0.0.0.255 area 0
ISP(config-router)#network 192.168.3.0 0.0.0.255 area 0

 

Мы настраиваем OSPF process 1 и указываем VRF, который хотим использовать, вот и все. Давайте сделаем то же самое для клиента Red:

Red1(config)#router ospf 1
Red1(config-router)#network 192.168.2.0 0.0.0.255 area 0
Red1(config-router)#network 2.2.2.2 0.0.0.0 area 0
Red2(config)#router ospf 1
Red2(config-router)#network 192.168.4.0 0.0.0.255 area 0
Red2(config-router)#network 4.4.4.4 0.0.0.0 area 0
ISP(config)#router ospf 2 vrf Red
ISP(config-router)#network 192.168.2.0 0.0.0.255 area 0
ISP(config-router)#network 192.168.4.0 0.0.0.255 area 0

 

 

Конфигурация аналогична, мне пришлось использовать второй process ID на маршрутизаторе ISP, поскольку первый используется для клиента Blue. Вот как выглядят таблицы маршрутизации VRF на маршрутизаторе ISP:

ISP#show ip route vrf Blue ospf

Routing Table: Blue

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 192.168.1.1, 00:00:24, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 192.168.3.3, 00:00:24, FastEthernet2/0

 

ISP#show ip route vrf Red ospf

Routing Table: Red

2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 192.168.2.2, 00:00:19, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 192.168.4.4, 00:00:19, FastEthernet3/0

 

 

В результате имеем две отдельные таблицы маршрутизации с префиксами от каждого VRF.

 

Конфигурация

Хотите проверить себя? Ниже вы найдете правильную конфигурацию для запуска каждого устройств.

 

Blue1

hostname Blue1
!
ip cef
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
!
end

 

Blue2

hostname Blue2
!
ip cef
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.3.3 255.255.255.0
!
router ospf 1
network 3.3.3.3 0.0.0.0 area 0
network 192.168.3.0 0.0.0.255 area 0
!
end

 

ISP

hostname ISP
!
ip cef
!
ip vrf Blue
!
ip vrf Red
!
interface FastEthernet0/0
ip vrf forwarding Blue
ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet1/0
ip vrf forwarding Red
ip address 192.168.2.254 255.255.255.0
!
interface FastEtherne2/0
ip vrf forwarding Blue
ip address 192.168.3.254 255.255.255.0
!
interface FastEthernet3/0
ip vrf forwarding Red
ip address 192.168.4.254 255.255.255.0
!
router ospf 1 vrf Blue
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!
router ospf 2 vrf Red
network 192.168.2.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
!
end

 

Red1

hostname Red1
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
!
end

 

Red2

hostname Red2
!
ip cef
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.4.4 255.255.255.0
!
router ospf 1
network 4.4.4.4 0.0.0.0 area 0
network 192.168.4.0 0.0.0.255 area 0
!
end

 

Это всё, о чем я хотел сказать про VRF Lite на Cisco. Но есть одно примечание: при такой конфигурации мы имеем один недостаток — это не масштабируемое решение. В нашем примере мы использовали только один маршрутизатор ISP, но что, если мы хотим использовать VRF Lite на Cisco и несколько маршрутизаторов ISP? Это мы обсудим позже.

 

 

Спасибо за уделенное время на прочтение статьи о том, как использовать технологию VRF Lite на Cisco!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
MPLS

Больше похожих постов

Результатов не найдено.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню