Настройка системы предотвращения вторжений (IPS) на маршрутизаторе Cisco

Настройка системы предотвращения вторжений (IPS) на маршрутизаторе Cisco

Новости

В данной статье рассмотрена настройка системы предотвращения вторжений (IPS) на маршрутизаторе Cisco. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

 

 

Видео инструкция на нашем YouTube канале:

 

Лабораторная работа доступна здесь: CCNA Security Configure an Intrusion Prevention System (IPS).

 

Конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup

line console 0
logging synchronous

interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no shut
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
no shut
exit

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

 

Конфигурации R2 после выполнения Части 1
hostname R2

no ip domain-lookup

line console 0
logging synchronous

interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
no shut
interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
no shut
exit

ip route 192.168.1.0 255.255.255.0 Serial0/0/0
ip route 192.168.3.0 255.255.255.0 Serial0/0/1

 

Конфигурации R3 после выполнения Части 1
hostname R3

no ip domain-lookup

line console 0
logging synchronous

interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.0
no shut

interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0/1

 

Конфигурации R3 после выполнения Части 2
show flash
mkdir ipsdir
delete flash:ipsdir/*
dir flash:ipsdir

crypto key pubkey-chain rsa
named-key realm-cisco.pub signature
key-string
30820122 300D0609 2A864886 F70D0101 01050003 82010F00 3082010A 02820101
00C19E93 A8AF124A D6CC7A24 5097A975 206BE3A2 06FBA13F 6F12CB5B 4E441F16
17E630D5 C02AC252 912BE27F 37FDD9C8 11FC7AF7 DCDD81D9 43CDABC3 6007D128
B199ABCB D34ED0F9 085FADC1 359C189E F30AF10A C0EFB624 7E0764BF 3E53053E
5B2146A9 D7A5EDE3 0298AF03 DED7A5B8 9479039D 20F30663 9AC64B93 C0112A35
FE3F0C87 89BCB7BB 994AE74C FA9E481D F65875D6 85EAF974 6D9CC8E3 F0B08B85
50437722 FFBE85B9 5E4189FF CC189CB9 69C46F9C A84DFBA5 7A0AF99E AD768C36
006CF498 079F88F8 A3B3FB1F 9FB7B3CB 5539E1D1 9693CCBB 551F78D2 892356AE
2F56D826 8918EF3C 80CA4F4D 87BFCA3B BFF668E9 689782A5 CF31CB6E B4B094D3
F3020301 0001
quit

ip ips name iosips

ip ips config location flash:ipsdir

ip http server

ip ips notify sdee

ip ips notify log

clock set 01:20:00 8 march 2015

service timestamps log datetime msec

logging 192.168.3.3

ip ips signature-category
category all
retired true
exit
category ios_ips basic
retired false
exit
exit

interface serial0/0/0
ip ips iosips in

interface g0/1
ip ips iosips in

copy tftp://192.168.3.3/IOS-S855-CLI.pkg idconf

show ip ips signature count

show ip ips all

ip ips signature-definition
signature 2004 0
status
retired false
enabled true
engine
event-action produce-alert
event-action deny-packet-inline
event-action reset-tcp-connection
exit
exit
exit

 

 

Спасибо за уделенное время на прочтение статьи о настройка системы предотвращения вторжений (IPS) на маршрутизаторе Cisco!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Ciscoкурсы по кибербезопасности,  полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

110
0
Рассмотрим как настроить многозоновый (multiarea) OSPF: протокол динамической маршрутизации для нескольких областей. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое

Результатов не найдено.

Меню