Как настроить роли административного доступа к маршрутизатору и защититься от взлома

Новости

Рассмотрим как настроить привилегии и роли административного доступа (create multiple role views, grant varying privileges, administative access) к маршрутизатору, а также некоторые дополнительные настройки по защите от взлома маршрутизатора. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

 

Видео инструкция на нашем YouTube канале:

 

Лабораторная работа доступна здесь: CCNA Security Lab Securing the Router for Administrative Access.

 

Конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no shut

interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
no shut

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации R2 после выполнения Части 1
hostname R2
no ip domain-lookup

interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
no shut

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.3 area 0

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации R3 после выполнения Части 1
hostname R3
no ip domain-lookup

interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.0
no shut

interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
no shut

router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации R1 после выполнения Части 2
security passwords min-length 10
enable algorithm-type scrypt secret cisco12345

line vty 0 4
password ciscovtypass
exec-timeout 5 0
transport input telnet
login

service password-encryption
banner motd $Unauthorized access strictly prohibited!$

username user01 algorithm-type scrypt secret user01pass

line console 0
login local

line vty 0 4
login local

ip domain-name ccnasecurity.com
username admin privilege 15 algorithm-type scrypt secret cisco12345

line vty 0 4
privilege level 15
login local
transport input ssh

crypto key generate rsa general-keys modulus 1024
ip ssh version 2
ip ssh time-out 90
ip ssh authentication-retries 2

 

 

Конфигурации R1 после выполнения Части 3
aaa new-model
enable view

parser view admin1
commands exec include all show
commands exec include all config terminal
commands exec include all debug

parser view admin2
secret admin2pass
commands exec include all show

parser view tech
secret techpasswd
commands exec include show version
commands exec include show interfaces
commands exec include show ip interface brief
commands exec include show parser view

 

 

Конфигурации R2 после выполнения Части 4
clock set 20:12:00 Dec 17 2014
ntp authentication-key 1 md5 NTPpassword
ntp trusted-key 1
ntp authenticate
ntp master 3

service timestamps log datetime msec
logging host 192.168.1.3
logging trap warnings

 

 

Конфигурации R1 после выполнения Части 4
ntp authentication-key 1 md5 NTPpassword
ntp trusted-key 1
ntp authenticate
ntp server 10.1.1.2
ntp update-calendar

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Ciscoкурсы по кибербезопасности,  полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Ушлый хакер долго обманывал десятки компаний, специалист по информационной безопасности где учиться Минск

Ушлый хакер долго обманывал десятки компаний, специалист по информационной безопасности где учиться Минск

52
0
Недавно власти США поймали хакера, который занимался мошенничеством. Прежде всего он обманывал как пользователей, так и компании. Помимо того, участвовал…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Most Viewed Posts
Схема выводов RJ45

Схема выводов RJ45

3,209
0
RJ45  — это разъем, состоящий из 8 металлических контактов. Схема выводов RJ45 показывает способ взаимодействия этого разъема с сетевыми устройствами.…
Create-a-Subnetting-Cheat-Sheet

Шпаргалка для работы с подсетью

221
0
Во время экзамена Cisco CCNA/CCNP Routing&Switching вы должны ответить на много вопросов, связанных с подсетями. Во время экзамена у вас…
Меню