Как настроить тупиковые области (stub area) OSPF на маршрутизаторе Cisco

Как настроить тупиковые области (stub area) OSPF на маршрутизаторе Cisco

Рассмотрим как настроить тупиковые области (stub area) OSPF на маршрутизаторе Cisco. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

Содержание:

Что такое тупиковые области

Специальные типы областей OSPF, которые называются тупиковыми (stub), были рассмотрены в данной статье. Это топология, которая будет использоваться для настройки stub area:

 

stub_area

Настройки протокола OSPF

Предварительно необходимо сделать базовые настройки и настройки адресации. Здесь приведены настройки протокола OSPF:

 

 

 

Были объявлены все интерфейсы в правильных областях OSPF, за исключением интерфейса loopback0 на R1. Этот интерфейс перераспределяется в OSPF и объявляется с помощью LSA типа 5.

 

Если посмотреть на R3, можно увидеть сеть 192.168.12.0/24 как межобластную (LSA типа 3) и 1.1.1.0/24 как внешнюю сеть с метрикой E2 (LSA типа 5). Теперь давайте изменим область 1 в тупиковую область:

 

 

Теперь посмотрим, что изменилось:

 

Тупиковая область блокирует сообщения LSA типа 5, поэтому больше не видно сеть 1.1.1.0/24. Однако он вставляет маршрут по умолчанию.

Настройки R1 R2 R3
Вот настройки для каждого устройства hostname R2
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
!
router ospf 1
area 1 stub
network 192.168.12.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 1
!
end
hostname R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router ospf 1
redistribute connected subnets
network 192.168.12.0 0.0.0.255 area 0
!
end
hostname R3
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
!
router ospf 1
area 1 stub
network 192.168.23.0 0.0.0.255 area 1
!
end

Выводы

Спасибо за уделенное время на прочтение статьи. Теперь вы знаете о том, как настроить тупиковые области OSPF на маршрутизаторах Cisco и оптимизировать работу домена маршрутизации.

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet / DevOps (программируемые системы) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco, Linux, кибербезопасность, DevOps / DevNet, Python с трудоустройством!

Спешите подать заявку! Группы стартуют 25 января, 26 февраля, 22 марта, 26 апреля, 24 мая, 21 июня, 26 июля, 23 августа, 20 сентября, 25 октября, 22 ноября, 20 декабря.
Что Вы получите?
  • Поможем стать экспертом по сетевой инженерии, кибербезопасности, программируемым сетям и системам и получить международные сертификаты Cisco, Linux LPI, Python Institute.
  • Предлагаем проверенную программу с лучшими учебниками от экспертов из Cisco Networking Academy, Linux Professional Institute и Python Institute, помощь сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и стартом карьеры в сфере IT — 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проведем вечерние онлайн-лекции на нашей платформе.
  • Согласуем с вами удобное время для практик.
  • Если хотите индивидуальный график — обсудим и реализуем.
  • Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
  • Всем, кто боится потерять мотивацию и не закончить обучение, предложим общение с профессиональным коучем.
А еще поможем Вам:
  • отредактировать или создать с нуля резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроиться на работу в Cisco по специальной программе. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco, Linux LPI, кибербезопасность, DevOps / DevNet, Python, подайте заявку или получите бесплатную консультацию.

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Поиск по сайту
Лучшее
Популярное
Рубрики

Свежие комментарии

Меню