Как настроить сервер и клиент DHCP для IPv4 на Cisco IOS

Как настроить сервер и клиент DHCP для IPv4 на Cisco IOS

Рассмотрим, как настроить коммутатор / маршрутизатор с ОС Cisco IOS в качестве сервера / клиента DHCP для IPv4 и упростить задачу распределения адресов в локальной сети. Исследуемая топология состоит из коммутатора Cisco 2960 с ПО Cisco IOS 15.0(2) LAN Base и маршрутизатора Cisco 2911 с ПО Cisco IOS 15.0 соответственно. Допускается использование других коммутаторов / маршрутизаторов и версий Cisco IOS.

Протокол динамического конфигурирования узла (Dynamic Host Configuration Protocol, DHCP) динамически назначает данные по IP-адресации узлам. DHCP v4 предназначен для сети IPv4. Это означает, что сетевому администратору не нужно тратить день на настройку IP-адресов для каждого устройства в сети. В небольшом доме или офисе это было бы не очень сложно, но любая большая сеть может иметь сотни, а то и тысячи устройств.

В данной статье будут рассмотрены настройки коммутатора в качестве DHCP-сервера и маршрутизатора в качестве DHCP-клиента.

 

Топология

 

 

Начальные настройки на коммутаторе

 

hostname LAN-switch
!
no ip domain lookup
!
line con 0
exec-t 0 0
logg sync
exit
!
interface range fastEthernet0/5-7
switchport mode access
spanning-tree portfast
exit
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
no shutdown
exit

 

Начальные настройки на маршрутизаторе

 

hostname LAN-router
!
no ip domain lookup
!
line con 0
exec-t 0 0
logg sync
exit
!
interface GigabitEthernet0/1
ip address dhcp
no shutdown
exit

 

Настройки DHCP-сервера на коммутаторе

 

Настроим DHCP-сервер для оконечных устройств:

 

ip dhcp excluded-address 192.168.1.2 192.168.1.10
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
exit

 

Настройка маршрутизатора в качестве DHCP-клиента

 

В целом для получения адреса на интерфейсе маршрутизатора используется команда:

 

interface GigabitEthernet0/1
ip address dhcp
exit

 

Однако если нужно выдать адрес статически, то необходимо знать не просто MAC-адрес нужного интерфейса маршрутизатора, а его DHCP Client Identifier (client ID). Client ID может быть представлен 2-мя способами:

  • 7-байтовое шестнадцатеричное представление, разделенное точками. Например, 01100.04f3.0158.b3, где 01 представляет тип среды передачи Ethernet, а оставшиеся байты представляют MAC-адрес DHCP-клиента.
  • 27-байтовое шестнадцатеричное представление, разделенное точками. Например, 7665.6e64.6f72.2d30.3032.342e.3937.6230.2e33.3734.312d.4661.302f.31. Эквивалентная строка ASCII для этого шестнадцатеричного значения — vendor-0024.97b0.3741, где vendor представляет поставщика, 0024.97b0.3741 представляет MAC-адрес исходящего интерфейса, и последние цифры — это название и номер исходящего интерфейса.

 

Cisco IOS по умолчанию использует последний вариант обозначения. Для того, чтобы перейти к более компактному представлению client ID нужно сделать дополнительные настройки:

 

interface GigabitEthernet0/1
ip address dhcp client-id GigabitEthernet0/1
exit

 

Уточнив MAC-адрес интерфейса GigabitEthernet0/1 маршрутизатора на коммутаторе нужно сделать настройку отдельного DHCP-сервера для маршрутизатора:

 

ip dhcp pool WAN
host 192.168.1.1 255.255.255.0
client-identifier 0188.1dfc.e4f8.b9
exit

 

Здесь 0188.1dfc.e4f8.b9:

  • 01 — тип среды Ethernet,
  • 881d.fce4.f8b9 — MAC-адрес интерфейса GigabitEthernet0/1 маршрутизатора.

 

Проверка настроек

 

show running-config | section ip dhcp
show ip dhcp binding
show ip dhcp server statistics

 

 

Как настроить сервер и клиент DHCP для IPv4 на Cisco IOS

 

 

 

Как настроить сервер и клиент DHCP для IPv4 на Cisco IOS

 

 

Спасибо за уделенное время на прочтение статьи о том, как настроить сервер и клиент DHCP v4 на коммутаторе / маршрутизаторе с ПО Cisco IOS!

 

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню