Настройка туннеля GRE в сети VPN

Новости

Рассмотрим как настроить незашифрованный туннель GRE VPN и убедиться, что сетевой трафик использует туннель. Также будет нужно настроить протокол маршрутизации OSPF внутри туннеля GRE VPN. Туннель GRE существует между пограничными маршрутизаторами в области 0 OSPF. Интернет-провайдер не знает о туннеле GRE. Для связи между пограничными маршрутизаторами и интернет-провайдером применяются статические маршруты по умолчанию. Исследуемая топология состоит из трех маршрутизаторов Cisco 2911 (2941) с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

CCNA-RS-Configuring-GRE-VPN-Tunnel

 

Видео инструкция на нашем YouTube канале:

 

Лабораторная работа доступна здесь: CCNA RS Configuring GRE VPN Tunnel.

 

Сценарий

Универсальная инкапсуляция при маршрутизации (GRE) — это протокол туннелирования, способный инкапсулировать различные протоколы сетевого уровня между двумя объектами по общедоступной сети, например, в Интернете.
GRE можно использовать в следующих ситуациях:
— подключение сети IPv6 по сетям IPv4;
— многоадресная рассылка пакетов, например OSPF и EIGRP, а также потоковая передача данных.
В этой статье будет настроен незашифрованный туннель GRE VPN и выполнена проверка, что сетевой трафик использует туннель. Также будет нужно настроить протокол маршрутизации OSPF внутри туннеля GRE VPN. Туннель GRE существует между маршрутизаторами WEST и EAST в области 0 OSPF. Интернет-провайдер не знает о туннеле GRE. Для связи между маршрутизаторами WEST и EAST и интернет-провайдером применяются статические маршруты по умолчанию.

 

Задачи

Часть 1. Настройка основных параметров устройства
Часть 2. Настройка туннеля GRE
Часть 3. Организация маршрутизации по туннелю GRE

 

Конфигурации WEST после выполнения Части 1
hostname WEST
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

interface gi0/1
ip address 172.16.1.1 255.255.255.0
no shut

interface S0/0/0
ip address 10.1.1.1 255.255.255.252
no shut

ip route 0.0.0.0 0.0.0.0 10.1.1.2

 

 

Конфигурации ISP после выполнения Части 1
hostname ISP
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

interface Loopback0
ip address 198.133.219.1 255.255.255.255

interface S0/0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface S0/0/1
ip address 10.2.2.2 255.255.255.252
no shut

ip route 172.16.1.0 255.255.255.0 10.1.1.1
ip route 172.16.2.0 255.255.255.0 10.2.2.1

 

 

Конфигурации EAST после выполнения Части 1
hostname EAST
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

interface gi0/1
ip address 172.16.2.1 255.255.255.0
no shut

interface S0/0/1
ip address 10.2.2.1 255.255.255.252
no shut

ip route 0.0.0.0 0.0.0.0 10.2.2.2

 

 

Конфигурации WEST после выполнения Части 2
interface tunnel 0
ip address 172.16.12.1 255.255.255.252
tunnel source s0/0/0
tunnel destination 10.2.2.1

 

 

Конфигурации EAST после выполнения Части 2
interface tunnel 0
ip address 172.16.12.2 255.255.255.252
tunnel source 10.2.2.1
tunnel destination 10.1.1.1

 

 

Конфигурации WEST после выполнения Части 3
router ospf 1
network 172.16.1.0 0.0.0.255 area 0
network 172.16.12.0 0.0.0.3 area 0

 

 

Конфигурации EAST после выполнения Части 3
router ospf 1
network 172.16.2.0 0.0.0.255 area 0
network 172.16.12.0 0.0.0.3 area 0

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

111
0
Рассмотрим как настроить многозоновый (multiarea) OSPF: протокол динамической маршрутизации для нескольких областей. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941…

1 комментарий. Оставить новый

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню