path control (контролируемая маршрутизация)

Как настроить path control (контролируемая маршрутизация) на основании заданных политик (PBR)

Новости

Рассмотрим как настроить path control (контролируемая маршрутизация) на основании заданных политик (PBR). Исследуемая топология состоит из четырех маршрутизаторов Cisco 2911 (2941) с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS. В зависимости от модели маршрутизатора и версии программного обеспечения Cisco IOS доступные команды и полученные результаты могут отличаться от показанных в этой статье.

 

Схема топологии следующая:

CCNP-R-lab-PBR-Configuration - path control (контролируемая маршрутизация)

 

Видео инструкция на нашем YouTube канале:

 

 

Сценарий

Маршрутизация на основе политик (policy based routing, PBR) позволяет маршрутизировать трафик на основании заданных политик. Относится к инструментам path control (контролируемая маршрутизация) .

 

CCNP-R-lab-PBR-Configuration-1 - path control (контролируемая маршрутизация)

 

PBR — это мощный и гибкий инструмент, который предлагает значительные преимущества с точки зрения реализации пользовательских политик для управления трафиком в сети.

PBR добавляет гибкости в сложную для управления среду, предоставляя возможность маршрутизации трафика на основе потребностей сети.

Он также предоставляет решения в тех случаях, когда юридические, договорные или политические ограничения диктуют направление трафика по определенным путям.

Применение PBR:

1. Исходный выбор транзитного провайдера
Политики PBR могут быть реализованы интернет-провайдерами и другими организациями для маршрутизации трафика, который исходит от разных групп пользователей через различные интернет-соединения.

2. QoS
Политики PBR могут быть реализованы для обеспечения качества обслуживания (QoS) дифференцированного трафика путем установки значений типа обслуживания (ToS) в заголовках IP-пакетов в маршрутизаторах на периферии сети и последующего использования механизмов организации очередей для определения приоритетов трафика в сетевом ядре или магистрали.

3. Экономия затрат
Политики PBR могут быть реализованы, чтобы направлять объемный трафик, связанный с конкретной деятельностью, на короткое время через высокоскоростную линию с более высокой пропускной способностью и поддерживать базовые возможности подключения по недорогой линии с низкой пропускной способностью для интерактивного трафика.

4. Распределение нагрузки
Политики PBR могут быть реализованы на основе характеристик трафика для распределения трафика между несколькими путями.

 

PBR может применяться как для сквозного трафика, так и для трафика, который генерируется маршрутизатором.

Примеры задач, которые PBR может решить:

  • Маршрутизировать трафик по любому признаку, который можно указать в списке контроля доступа ACL (IP отправителя и получателя, порты TCP/UDP):
    • Маршрутизировать VoIP трафик через один канал, а весь остальной, через другой,
    • Маршрутизировать трафик пользователей одной VLAN через один канал, а пользователей другой VLAN через другой.
    • Маршрутизировать трафик, который генерирует маршрутизатор, по определенному пути.
  • Решать задачи сбалансированного распределения нагрузки по сети.
  • Решать задачи, связанные с качеством обслуживания трафика, критичного к каким-либо характеристикам сети.

PBR перехватывает пакеты до стандартной маршрутизации и отправляет пакеты по настроенным правилам. Если для группы пакетов в PBR не указано как их маршрутизировать, то они будут отправлены по стандартным правилам маршрутизации.

В этой статье будет показана настройка path control (контролируемая маршрутизация) на основании заданных политик (PBR).

 

Задачи

  • Настройка и проверка маршрутизации на основе политик.
  • Выбор необходимых инструментов и команд для настройки работы маршрутизации на основе политик.
  • Проверка конфигурации и работы PBR, используя правильные команды show и debug.

 

Конфигурации R1
hostname R1
no ip domain-lookup

line con 0
exec-timeout 0 0
logging synchronous
exit

interface Lo1
description R1 LAN
ip address 192.168.1.1 255.255.255.0
exit

interface Serial0/0/0
description R1 --> R2
ip address 172.16.12.1 255.255.255.248
clock rate 128000
bandwidth 128
no shutdown
exit

interface Serial0/0/1
description R1 --> R3
ip address 172.16.13.1 255.255.255.248
bandwidth 64
no shutdown
exit

router eigrp 1
network 192.168.1.0
network 172.16.12.0 0.0.0.7
network 172.16.13.0 0.0.0.7
no auto-summary
end

 

 

Конфигурации R2
hostname R2
no ip domain-lookup

line con 0
exec-timeout 0 0
logging synchronous
exit

interface Lo2
description R2 LAN
ip address 192.168.2.1 255.255.255.0
exit

interface Serial0/0/0
description R2 --> R1
ip address 172.16.12.2 255.255.255.248
bandwidth 128
no shutdown
exit

interface Serial0/0/1
description R2 --> R3
ip address 172.16.23.2 255.255.255.248
clock rate 128000
bandwidth 128
no shutdown
exit

router eigrp 1
network 192.168.2.0
network 172.16.12.0 0.0.0.7
network 172.16.23.0 0.0.0.7
no auto-summary
end

 

 

Конфигурации R3
hostname R3
no ip domain-lookup

line con 0
exec-timeout 0 0
logging synchronous
exit

interface Lo3
description R3 LAN
ip address 192.168.3.1 255.255.255.0
exit

interface Serial0/0/0
description R3 --> R1
ip address 172.16.13.3 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
exit

interface Serial0/0/1
description R3 --> R2
ip address 172.16.23.3 255.255.255.248
bandwidth 128
no shutdown
exit

interface Serial0/1/0
description R3 --> R4
ip address 172.16.34.3 255.255.255.248
ip policy route-map R3-to-R1
clock rate 64000
bandwidth 64
no shutdown
exit

router eigrp 1
network 192.168.3.0
network 172.16.13.0 0.0.0.7
network 172.16.23.0 0.0.0.7
network 172.16.34.0 0.0.0.7
no auto-summary
exit

ip access-list standard PBR-ACL
remark ACL matches R4 LAN B traffic
permit 192.168.4.128 0.0.0.127
exit

access-list 1 permit 192.168.4.0 0.0.0.255

route-map R3-to-R1 permit 10
description RM to forward LAN B traffic to R1
match ip address PBR-ACL
set ip next-hop 172.16.13.1
end

 

 

Конфигурации R4
hostname R4
no ip domain-lookup

line con 0
exec-timeout 0 0
logging synchronous
exit

interface Lo4
description R4 LAN A
ip address 192.168.4.1 255.255.255.128
exit

interface Lo5
description R4 LAN B
ip address 192.168.4.129 255.255.255.128
exit

interface Serial0/0/0
description R4 --> R3
ip address 172.16.34.4 255.255.255.248
bandwidth 64
no shutdown
exit

router eigrp 1
network 192.168.4.0
network 172.16.34.0 0.0.0.7
no auto-summary
end

 

 

Спасибо за уделенное время на прочтение статьи о том, как настроить path control (контролируемая маршрутизация) на основании заданных политик (PBR)!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ)

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню