Как настроить зеркалирование портов (Port mirroring, Cisco SPAN и Wireshark)

Новости

Рассмотрим как настроить зеркалирование портов (Port mirroring, Cisco SPAN и Wireshark).

Для исследований используется маршрутизатор с интегрированными сетевыми сервисами (ISR) Cisco 1941 с операционной системой Cisco IOS версии 15.4(3) (образ universalk9). Также используются коммутаторы Cisco Catalyst 2960 с операционной системой Cisco IOS версии 15.0(2) (образ lanbasek9). Допускается использование коммутаторов и маршрутизаторов других моделей, а также других версий операционной системы Cisco IOS. В зависимости от модели устройства и версии Cisco IOS доступные команды и результаты их выполнения могут отличаться от тех, которые показаны в эксперименте.

 

Схема топологии следующая:

isco-CCNA-RS-Implement-Local-SPAN

 

Видео инструкция на нашем YouTube канале:

 

Лабораторная работа доступна здесь: Cisco CCNA RS Implement Local SPAN.

 

Сценарий

Как сетевой администратор, вы хотите анализировать входящий и исходящий трафик локальной сети. Для этого вы настроите зеркалирование портов на коммутационном порте, подключенном к маршрутизатору, и зеркально скопируете весь трафик на другой коммутационный порт. Цель состоит в отправке зеркалированного трафика в систему обнаружения вторжений (IDS) для анализа. В этой первоначальной реализации вы будете отправлять весь зеркалированный трафик на ПК, который будет перехватывать трафик для анализа, используя программу прослушивания портов. Для настройки зеркалирования портов будет использоваться функция анализатора коммутируемых портов (SPAN) на коммутаторе Cisco. Анализатор коммутируемых портов — это тип зеркалирования портов, в котором копии кадров, поступающих на порт, отправляются на другой порт того же коммутатора. Очень часто можно найти устройство, на котором работает анализатор трафика пакетов или система обнаружения вторжений (IDS), подключенные к зеркалированному порту.

 

Задачи

Часть 1. Построение сети и проверка соединения
Часть 2. Настройка локального анализатора коммутируемых портов и сбор копируемого трафика с помощью ПО Wireshark

 

Конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
no shut

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации S1 после выполнения Части 1
hostname R1
no ip domain-lookup

interface VLAN1
ip address 192.168.1.2 255.255.255.0
no shut

line con 0
exec-timeout 5 0
logging synchronous
exit

 

 

Конфигурации S2 после выполнения Части 1
hostname S2
no ip domain-lookup

interface VLAN 1
ip address 192.168.1.3 255.255.255.0
no shut

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации S1 после выполнения Части 2
monitor session 1 source interface f0/5
monitor session 1 destination interface f0/6

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Обнаружены уязвимости в составе Vertiv Avocent MergePoint EMS BMC, информационная безопасность курсы повышения квалификации Санкт-Петербург

Обнаружены уязвимости в составе Vertiv Avocent MergePoint EMS BMC, информационная безопасность курсы повышения квалификации Санкт-Петербург

107
0
Недавно специалисты из Eclypsium смогли обнаружить существенные уязвимости, которые мешали работе Gigabyte и Lenovo. В этих компаниях была нарушена информационная…
Защита информации: использование уязвимостей

Защита информации: использование уязвимостей, обучение техническая защита информации Санкт-Петербург

76
0
Самый распространенный способ проникновения злоумышленника в операционную систему компьютера или смартфона — это использование уязвимостей. Существует даже специальное обучение техническая…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню