Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

Новости

Рассмотрим как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941 с образом Cisco IOS Release 15.4 IP Base. Допускается использование маршрутизаторов других моделей, а также других версий операционной системы Cisco IOS. В зависимости от модели устройства и версии Cisco IOS доступные команды и результаты их выполнения могут отличаться от тех, которые показаны в этой статье.

Схема топологии следующая:

 

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

 

Сценарий

Для улучшения эффективности и масштабируемости в OSPF поддерживается иерархическая маршрутизация, использующая понятие областей. Область (area) OSPF — это группа маршрутизаторов, использующих в своих базах данных состояний каналов (LSDB) общие и одинаковые данные о состоянии каналов. Если большая область OSPF разделена на области меньшего размера, такая архитектура называется OSPF для нескольких областей. Использование OSPF для нескольких областей является целесообразным в сетях большего размера, поскольку это позволяет сократить потребление ресурсов ЦП и памяти.

В этой статье будет показана настройка сети OSPFv2 для нескольких областей с межобластными суммарными маршрутами.

 

Сделаем базовые настройки маршрутизаторов.

Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

 

Настроим интерфейсы.

R1(config)# interface Lo0
R1(config-if)# description Connection to Internet
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# exit
R1(config)# interface Lo1
R1(config-if)# description Connection to LAN1
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# exit
R1(config)# interface Lo2
R1(config-if)# description Connection to LAN2
R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# exit
R1(config)# interface Gi0/2
R1(config-if)# description R1 -> R2
R1(config-if)# ip address 192.168.12.1 255.255.255.252
R1(config-if)# no shutdown
R1(config-if)# end

 

R2(config)# interface Lo0
R2(config-if)# description Connection to LAN3
R2(config-if)# ip address 192.168.3.1 255.255.255.0
R2(config)# exit
R2(config)# interface Gi0/0
R2(config-if)# description R2 -> R1
R2(config-if)# ip address 192.168.12.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface Gi0/2
R2(config-if)# description R2 -> R3
R2(config-if)# ip address 192.168.23.1 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# end

 

R3(config)# interface Lo0
R3(config-if)# description Connection to LAN3
R3(config-if)# ip address 192.168.4.1 255.255.255.0
R3(config)# exit
R3(config-if)# interface Gi0/0
R3(config-if)# description R3 -> R2
R3(config-if)# ip address 192.168.23.2 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# end

 

Настроим OSPF.

 

R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 1
R1(config-router)# network 192.168.2.0 0.0.0.255 area 1
R1(config-router)# network 192.168.12.0 0.0.0.3 area 0

 

R2(config)# router ospf 1
R2(config-router)# network 192.168.3.0 0.0.0.255 area 2
R2(config-router)# network 192.168.12.0 0.0.0.3 area 0
R2(config-router)# network 192.168.23.0 0.0.0.3 area 2

 

R3(config)# router ospf 1
R2(config-router)# network 192.168.4.0 0.0.0.255 area 2
R2(config-router)# network 192.168.23.0 0.0.0.3 area 2

 

Также поменяем тип сети в каналах между R1 и R2, R2 и R3 на «точка-точка», чтобы не тратились ресурсы на выбор DR/BDR:

 

R1(config)# interface Gi0/2
R1(config-if)# ip ospf network type point-to-point
R1(config-if)# exit

 

R2(config)# interface Gi0/2
R2(config-if)# ip ospf network type point-to-point
R2(config-if)# exit
R2(config)# interface Gi0/0
R2(config-if)# ip ospf network type point-to-point
R2(config-if)# exit

 

R3(config)# interface Gi0/0
R3(config-if)# ip ospf network type point-to-point
R3(config-if)# exit

 

Настройка межобластных суммарных маршрутов.

 

OSPF не выполняет автоматическое объединение. Объединение межобластных маршрутов необходимо вручную настроить на маршрутизаторах ABR. С помощью команд show можно будет наблюдать, каким образом объединение влияет на таблицу маршрутизации и базы данных LSDB.

R1(config)# router ospf 1
R1(config-router)# area 1 range 192.168.0.0 255.255.252.0
R1(config-router)# exit

Теперь вы знаете, как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей.

 

Спасибо за уделенное время на прочтение статьи о том, как настроить многозоновый OSPF!

Также советуем прочесть еще одну статью: Как настроить VPN (site-to-site) на основе IPsec с помощью Strongswan на CentOS/RHEL 8?

Если возникли вопросы — задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ)

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое

Настройка туннеля GRE в сети VPN

350
1 комментарий
Рассмотрим как настроить незашифрованный туннель GRE VPN и убедиться, что сетевой трафик использует туннель. Также будет нужно настроить протокол маршрутизации…
Меню