Как настроить BGB

Как настроить BGP с подключением к двум интернет-провайдерам

Новости

Рассмотрим как настроить BGP — протокол динамической маршрутизации на маршрутизаторе Cisco. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941 с образом Cisco IOS Release 15.4 IP Base. Допускается использование маршрутизаторов других моделей, а также других версий операционной системы Cisco IOS. В зависимости от модели устройства и версии Cisco IOS доступные команды и результаты их выполнения могут отличаться от тех, которые показаны в этой статье.

Схема топологии следующая:

 

 

Сценарий

Международное туристическое агентство (International Travel Agency, ITA) широко использует Интернет для продаж. По этой причине ITA решила создать решение для несколько подключений (multihomed) к интернет-провайдерам ISP и заключила контракт с двумя ISP на подключение к Интернету с отказоустойчивостью. Поскольку ITA подключается к двум различным поставщикам услуг, необходимо настроить BGP, который работает между граничным маршрутизатором ITA и двумя маршрутизаторами ISP.

 

Сделаем базовые настройки маршрутизаторов.

Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

 

Настроим интерфейсы.

ISP1(config)# interface Lo0
ISP1(config-if)# description ISP1 Internet Network
ISP1(config-if)# ip address 10.1.1.1 255.255.255.0
ISP1(config-if)# exit
ISP1(config)# interface Gi0/0
ISP1(config-if)# description ISP1 -> ITA
ISP1(config-if)# ip address 10.0.0.1 255.255.255.252
ISP1(config-if)# no shutdown
ISP1(config-if)# end
ISP1#

 

ITA(config)# interface Lo0
ITA(config-if)# description Core router network link 1
ITA(config-if)# ip address 192.168.0.1 255.255.255.0
ITA(config)# exit
ITA(config-if)# interface Lo1
ITA(config-if)# description Core router network link 2
ITA(config-if)# ip address 192.168.1.1 255.255.255.0
ITA(config-if)# exit
ITA(config)# interface Gi0/0
ITA(config-if)# description ITA -> ISP1
ITA(config-if)# ip address 10.0.0.2 255.255.255.252
ITA(config-if)# no shutdown
ITA(config-if)# exit
ITA(config)# interface Gi0/2
ITA(config-if)# description ITA -> ISP2
ITA(config-if)# ip address 172.16.0.2 255.255.255.252
ITA(config-if)# no shutdown
ITA(config-if)# end
ITA#

 

ISP2(config)# interface Lo0
ISP2(config-if)# description ISP2 Internet Network
ISP2(config-if)# ip address 172.16.1.1 255.255.255.0
ISP2(config)# exit
ISP2(config-if)# interface Gi0/0
ISP2(config-if)# description ISP2 -> ITA
ISP2(config-if)# ip address 172.16.0.1 255.255.255.252
ISP2(config-if)# no shutdown
ISP2(config-if)# end
ISP2#

 

Настроим BGP.

ISP1(config)# router bgp 200
ISP1(config-router)# neighbor 10.0.0.2 remote-as 100
ISP1(config-router)# network 10.1.1.0 mask 255.255.255.0
ISP2(config)# router bgp 300
ISP2(config-router)# neighbor 172.16.0.2 remote-as 100
ISP2(config-router)# network 172.16.1.0 mask 255.255.255.0
ITA(config)# router bgp 100
ITA(config-router)# neighbor 10.0.0.1 remote-as 200
ITA(config-router)# neighbor 172.16.0.1 remote-as 300
ITA(config-router)# network 192.168.0.0
ITA(config-router)# network 192.168.1.0

Настроим маршрутизатор ITA так, чтобы он объявлял только сети ITA 192.168.0.0 и 192.168.1.0 обоим провайдерам.

access-list 1 permit 192.168.0.0 0.0.1.255
ITA(config)# router bgp 100
ITA(config-router)# neighbor 10.0.0.1 distribute-list 1 out
ITA(config-router)# neighbor 172.16.0.1 distribute-list 1 out

 

Настроим основной и резервный маршруты с помощью плавающих статических маршрутов.

ITA(config)# ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
ITA(config)# ip route 0.0.0.0 0.0.0.0 172.16.0.1 220

 

 

Спасибо за уделенное время на прочтение статьи о том, как настроить BGP!

Если возникли вопросы — задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ)

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

Как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей

131
0
Рассмотрим как настроить многозоновый OSPF: протокол динамической маршрутизации для нескольких областей. Исследуемая топология состоит из трех маршрутизаторов Cisco 1941 с…
Владельцы биржи Eterbase потеряли 5,4 миллиона долларов, информационная безопасность вузы магистратура Ташкент

Владельцы биржи Eterbase потеряли 5,4 миллиона долларов, информационная безопасность вузы магистратура Ташкент

101
0
Хакеры похитили из активов криптовалютной биржи Eterbase более 5 миллионов долларов. Представители словацкой компании рассказали некоторые подробности об инциденте. Они…

2 комментария. Оставить новый

  • Доброе день коллега у меня такое сомнения что у вас так в раелном сети не работает, например я такое сделал, и у меня еще очень много когфигом там еще NAT ALC HSRP IP SLA TRACK e.t.c
    Прошу прощение если я ошибаюсь исправьте мне!
    С уважением Парвин
    Ответить
  • если вам интересно могу с вами сотрудничать
    Ответить

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Внутренняя сессия BGP (IBGP)

Внутренняя сессия BGP (IBGP)

310
0
Сегодня мы расскажем о том, что такое внутренняя сессия BGP. BGP (Border Gateway Protocol) — протокол динамической маршрутизации. Относится к…
Меню