Как упростить настройки маршрутизации EIGRP для IPv4 и IPv6 с помощью именованного метода (named EIGRP)

Новости

Рассмотрим как настроить EIGRP для Dual Stack (IPv4 и IPv6) с помощью универсального метода — именованного EIGRP (named EIGRP). Исследуемая топология состоит из четырех маршрутизаторов Cisco 2911 (2941) с ПО Cisco IOS версии 15. Допускается использование других маршрутизаторов и версий Cisco IOS. В зависимости от модели маршрутизатора и версии программного обеспечения Cisco IOS доступные команды и полученные результаты могут отличаться от показанных в этой статье.

 

Схема топологии следующая:

CCNP-R-lab-EIGRP-Named-Configuration

 

Видео инструкция на нашем YouTube канале:

 

Сценарий

То, что известно как «классический» EIGRP, требует отдельных режимов конфигурации EIGRP и команд для IPv4 и IPv6. Каждый процесс настраивается отдельно, router eigrp as-number для IPv4 и ipv6 router eigrp as-number для IPv6.
Именованный EIGRP использует функцию семейства адресов (address family, AF) для унификации процесса настройки при реализации как IPv4, так и IPv6. В этой статье будет показана настройка EIGRP для IPv4 и IPv6.

 

Задачи

  • Настройка адресации и маршрутизации с помощью именованного EIGRP для IPv4 и IPv6.
  • Проверка именованной конфигурации EIGRP.
  • Настройка и проверка пассивных интерфейсов в именованном режиме конфигурации EIGRP.
  • Настройка и проверка маршрута по умолчанию, используя именованный режим конфигурации EIGRP.

 

Базовые конфигурации R1
hostname R1
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

ipv6 unicast-routing

interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:1::1/64
no shutdown

interface Serial0/0/0
ip address 192.168.2.1 255.255.255.252
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:2::1/64
clock rate 64000
no shutdown

 

 

Базовые конфигурации R2
hostname R2
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

ipv6 unicast-routing

interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:3::1/64
no shutdown

interface Serial0/0/0
ip address 192.168.2.2 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:2::2/64
no shutdown

interface Serial0/0/1
ip address 192.168.4.1 255.255.255.252
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:CAFE:4::1/64
clock rate 64000
no shutdown

 

 

Базовые конфигурации R3
hostname R3
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

ipv6 unicast-routing

interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:5::1/64
no shutdown

interface Serial0/0/1
ip address 192.168.4.2 255.255.255.252
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:CAFE:4::2/64
no shutdown

interface Serial0/1/0
ip address 192.168.77.2 255.255.255.0
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:FEED:77::2/64
clock rate 64000
no shutdown

 

 

Базовые конфигурации R4
hostname R4
no ip domain-lookup

line con 0
exec-timeout 5 0
logging synchronous

ipv6 unicast-routing

interface Serial0/0/0
ip address 192.168.77.1 255.255.255.0
ipv6 address FE80::4 link-local
ipv6 address 2001:DB8:FEED:77::1/64
no shutdown

ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2

 

 

Финальные конфигурации R1
router eigrp DUAL-STACK

address-family ipv4 unicast autonomous-system 4

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

topology base
exit-af-topology
network 192.168.1.0
network 192.168.2.0 0.0.0.3
eigrp router-id 1.1.1.1
exit-address-family

address-family ipv6 unicast autonomous-system 6

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

topology base
exit-af-topology
eigrp router-id 1.1.1.1
exit-address-family

 

 

Финальные конфигурации R2
router eigrp DUAL-STACK

address-family ipv4 unicast autonomous-system 4

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

topology base
exit-af-topology
network 192.168.2.0 0.0.0.3
network 192.168.3.0
network 192.168.4.0 0.0.0.3
eigrp router-id 2.2.2.2
exit-address-family

address-family ipv6 unicast autonomous-system 6

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

topology base
exit-af-topology
eigrp router-id 2.2.2.2
exit-address-family

 

 

Финальные конфигурации R3
router eigrp DUAL-STACK

address-family ipv4 unicast autonomous-system 4

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

topology base
redistribute static
exit-af-topology
network 192.168.4.0 0.0.0.3
network 192.168.5.0
eigrp router-id 3.3.3.3
exit-address-family

address-family ipv6 unicast autonomous-system 6

af-interface GigabitEthernet0/0
passive-interface
exit-af-interface

af-interface Serial0/1/0
shutdown
exit-af-interface

topology base
redistribute static
exit-af-topology
eigrp router-id 3.3.3.3
exit-address-family

ip route 0.0.0.0 0.0.0.0 192.168.77.1

ipv6 route ::/0 Serial0/1/0 2001:DB8:FEED:77::1

 

 

Финальные конфигурации R4
ipv6 route 2001:DB8:CAFE::/48 2001:DB8:FEED:77::2
ip route 0.0.0.0 0.0.0.0 192.168.77.2

 

 

Спасибо за уделенное время на прочтение статьи!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ)

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Новая атака BLESA угрожает миллиардам Bluetooth-устройств, курсы переподготовки по информационной безопасности Минск

Новая атака BLESA угрожает миллиардам Bluetooth-устройств, курсы переподготовки по информационной безопасности Минск

49
0
Исследователи обнаружили новый метод атаки уязвимых Bluetooth-устройств. Если хакеры начнут ее эксплуатировать, но смогут заразить миллиарды приборов по всему миру.…
Российские хакеры похитили почти 17 миллионов долларов, курс по кибербезопасности секреты хакеров Минск

Российские хакеры похитили почти 17 миллионов долларов, курс по кибербезопасности секреты хакеров Минск

47
0
Власти США предъявили обвинения двум российским хакерам во взломе криптовалютных бирж. Более того, правоохранительные органы смогли собрать достаточно улик. Исследователи,…

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Most Viewed Posts
How-to-find-IPv6-Prefix

Как найти префикс IPv6?

360
0
Адреса IPv4 имеют маску подсети, но вместо ввода типа 255.255.255.0 в IPv6 мы используем длину префикса. Ниже приведен пример префикса IPv6:…

Как отключить IPv6 в CentOS 8?

324
1 комментарий
Интернет-протокол версии 6 (IPv6) — это идентификатор сетевого интерфейса, который подключен к компьютерной сети IPv6. Если вы не хотите использовать…
Меню