Как развернуть отказоустойчивую локальную сеть: повышение производительности (Etherchannel) и резервирование на первом переходе (FHRP)

Новости

Рассмотрим как развернуть отказоустойчивую локальную сеть с повышением производительности (Etherchannel) и резервированием на первом переходе (FHRP).

Исследуемая топология состоит из трех маршрутизаторов с интегрированными сетевыми сервисами (ISR) Cisco 1941 с операционной системой Cisco IOS версии 15.2(4)M3 (образ universalk9). Также используются коммутаторы Cisco Catalyst 2960 с операционной системой Cisco IOS версии 15.0(2) (образ lanbasek9). Допускается использование других маршрутизаторов/коммутаторов и версий Cisco IOS.

 

Схема топологии следующая:

CCNA-RS-Lab-Configure-Etherchannel-HSRP

 

Видео инструкция на нашем YouTube канале:

 

 

Лабораторная работа доступна здесь: CCNA RS Lab Configure Etherchannel and HSRP.

 

Сценарий

Связующее дерево обеспечивает резервирование коммутаторами в локальной сети, не допуская возникновения петель. Но оно не позволяет организовать в сети резервирование шлюзов по умолчанию для устройств конечных пользователей на случай сбоя одного из маршрутизаторов. Протоколы обеспечения избыточности на первом хопе (First Hop Redundancy Protocols, FHRP) предоставляют избыточные шлюзы по умолчанию для конечных устройств. При этом конфигурация конечного пользователя не требуется. В этой статье будет рассмотрена настройка протокола VRRP, являющегося протоколом FHRP.

Агрегирование каналов позволяет создавать логические каналы, состоящие из двух или более физических каналов. Таким образом увеличивается пропускная способность, а также используется только один физический канал. Агрегирование каналов также обеспечивает избыточность в случае сбоя одного из каналов.

В этой статье будет рассмотрена настройка EtherChannel — тип агрегирования каналов, который используется в коммутируемых сетях. Вы настроите EtherChannel с помощью протокола агрегирования портов (PAgP) и протокола управления агрегированием каналов (LACP).

 

Задачи

Часть 1. Построение сети и проверка соединения
Часть 2. Настройка обеспечения избыточности на первом хопе с помощью HSRP
Часть 3. Настройка LACP

 

Etherchannel: конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no shut

interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
no shut

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

 

Etherchannel: конфигурации R2 после выполнения Части 1
hostname R2
no ip domain-lookup

interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
no shut

interface Loopback0
ip address 209.165.200.225 255.255.255.224

ip route 0.0.0.0 0.0.0.0 lo0

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.3 area 0
default-information originate

line con 0
exec-timeout 5 0
logging synchronous
exit

 

 

Etherchannel: конфигурации R3 после выполнения Части 1
hostname R3
no ip domain-lookup

interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.0
no shut

interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
no shut

router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

 

Etherchannel: конфигурации R1 после выполнения Части 2
interface g0/1
vrrp 1 ip 192.168.1.254
vrrp 1 priority 150

 

 

Etherchannel: конфигурации R2 после выполнения Части 2
interface g0/1
vrrp 1 ip 192.168.1.254
Etherchannel: конфигурации S1 после выполнения Части 3
interface range f0/3-4
switchport mode trunk
switchport trunk native vlan 99
channel-group 2 mode active
no shutdown

 

 

Etherchannel: конфигурации S2 после выполнения Части 3
interface range f0/3-4
switchport mode trunk
switchport trunk native vlan 99
channel-group 2 mode passive
no shutdown

 

 

Спасибо за уделенное время на прочтение статьи о том, как развернуть отказоустойчивую локальную сеть: повышение производительности (Etherchannel) и резервирование на первом переходе (FHRP)!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Владельцы биржи Eterbase потеряли 5,4 миллиона долларов, информационная безопасность вузы магистратура Ташкент

Владельцы биржи Eterbase потеряли 5,4 миллиона долларов, информационная безопасность вузы магистратура Ташкент

100
0
Хакеры похитили из активов криптовалютной биржи Eterbase более 5 миллионов долларов. Представители словацкой компании рассказали некоторые подробности об инциденте. Они…

2 комментария. Оставить новый

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Стекирование коммутаторов Cisco. Базовая настройка и пошаговая конфигурация.

Стекирование коммутаторов Cisco. Базовая настройка и пошаговая конфигурация.

905
1 комментарий
Стекирование коммутаторов — это функция некоторых коммутаторов уровня доступа Cisco, которая позволяет создавать единое логическое устройство из многих отдельных устройств…
Меню