Как защитить административный доступ на маршрутизаторе Cisco с помощью AAA и RADIUS

Новости

Как защитить административный доступ на маршрутизаторе Cisco с помощью AAA и RADIUS. Рассмотрим как построить сеть из нескольких маршрутизаторов и использовать команды CLI для настройки базовой локальной аутентификации с помощью AAA. Установим на внешнем компьютере программное обеспечение RADIUS и будем использовать AAA для аутентификации пользователей с помощью сервера RADIUS.

Исследуемая топология состоит из трех маршрутизаторов Cisco 1941 с ПО Cisco IOS Release 15.4(3)M2 (с лицензией Security Technology Package). Допускается использование других маршрутизаторов и версий Cisco IOS.

 

Схема топологии следующая:

CCNA-Security-Securing-Administrative-Access-Using-AAA-and-RADIUS

 

Видео инструкция на нашем YouTube канале:

 

Лабораторная работа доступна здесь: CCNA Security Securing Administrative Access Using AAA and RADIUS.

 

Сценарий

Самым распространенным способом обеспечения безопасного доступа к маршрутизатору является создание паролей для линий консоли, vty и aux. При попытке доступа к маршрутизатору у пользователя будет запрашиваться только пароль. Настройка секретного пароля в привилегированном режиме повышает уровень безопасности, но в любом случае для каждого уровня доступа требуется только основной пароль.

Помимо основных паролей, в локальной базе данных маршрутизатора можно настроить отдельные имена или учетные записи пользователей с разными уровнями привилегий, которые могут применяться ко всему маршрутизатору. Когда для линий консоли, vty или aux настроено обращение к этой локальной базе данных, то при использовании любой из этих линий для доступа к маршрутизатору пользователю предлагается ввести имя и пароль.

Для дополнительного контроля над процессом входа может применяться метод аутентификации, авторизации и учета (AAA). Для обеспечения базовой аутентификации функцию AAA можно настроить на доступ к локальной базе данных при вводе имен пользователей. Кроме того, могут быть определены запасные процедуры. Однако данный подход не обладает хорошей масштабируемостью, так как его нужно настраивать на каждом маршрутизаторе. Для обеспечения максимальной масштабируемости и максимально эффективного применения AAA, данную функцию нужно использовать совместно с базой данных внешнего сервера TACACS+ или RADIUS. При попытке пользователя войти в систему маршрутизатор обращается к внешнему серверу базы данных для проверки действительности имени пользователя и пароля.

В данной статье на маршрутизаторах Cisco с помощью команд CLI будет настроена базовая локальная аутентификации с помощью AAA. Также установим на внешнем компьютере программное обеспечение RADIUS и будем использовать AAA для аутентификации пользователей с помощью сервера RADIUS.

 

Задачи

Часть 1. Настройка основных параметров устройства
Часть 2. Настройка локальной аутентификации
Часть 3. Настройка локальной аутентификации с помощью AAA
Часть 4. Настройка централизованной аутентификации с помощью AAA и RADIUS

 

Конфигурации R1 после выполнения Части 1
hostname R1
no ip domain-lookup
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no shut

interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
no shut

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

 

Конфигурации R2 после выполнения Части 1
hostname R2
no ip domain-lookup

interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
no shut

router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.3 area 0

line con 0
exec-timeout 5 0
logging synchronous
password ciscoconpass
exit

security passwords min-length 10
enable algorithm-type scrypt secret cisco12345

line aux 0
password ciscoauxpass
exec-timeout 5 0
login
exit

line vty 0 4
password ciscovtypass
exec-timeout 5 0
login
exit

service password-encryption
banner motd $Unauthorized access strictly prohibited!$

 

 

Конфигурации R3 после выполнения Части 1
hostname R3
no ip domain-lookup

interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.0
no shut

interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
no shut

router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0
passive-interface fa 0/1

line con 0
exec-timeout 5 0
logging synchronous

 

Конфигурации R1 после выполнения Части 2
username user01 algorithm-type scrypt secret user01pass

line console 0
login local
exit

line vty 0 4
login local
transport input telnet
exit

line aux 0
login local
exit

 

 

Конфигурации R3 после выполнения Части 3
username Admin01 privilege 15 algorithm-type scrypt secret Admin01pass

aaa new-model
aaa authentication login default local-case none
aaa authentication login TELNET_LINES local

line vty 0 4
login local
transport input telnet
login authentication TELNET_LINES
exit

clock set 14:15:00 13 September 2019

 

 

Конфигурации R1 после выполнения Части 4
aaa new-model
aaa authentication login default group radius none
radius server CCNAS
key WinRadius
address ipv4 192.168.1.3 auth-port 1812 acct-port 1813

aaa authentication login TELNET_LINES group radius

line vty 0 4
login local
transport input telnet
login authentication TELNET_LINES
exit

 

 

Спасибо за уделенное время на прочтение статьи об AAA и RADIUS!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое

Результатов не найдено.

Меню