Как улучшить безопасность и настроить фильтрацию трафика внутри VLAN с помощью VACL

Как улучшить безопасность и настроить фильтрацию трафика внутри VLAN с помощью VACL

Рубрики:

Новости

Метки:

, , , ,

Рассмотрим, как настроить фильтрацию трафика в пределах одной IP-сети (VLAN) с помощью инструмента VACL (VLAN Access Control List) на коммутаторе Cisco Catalyst. Исследуемая топология состоит из коммутатора Cisco Catalyst 3560 или 2960 с ПО Cisco IOS 15.0(2) IP Services и LAN Base соответственно. Допускается использование других коммутаторов и версий Cisco IOS.

Существуют разные способы фильтрации трафика на сетевых устройствах. Их общее название — списки контроля доступа (Access control lists, ACL). Те списки контроля доступа, которые реализуются на маршрутизаторе, еще иногда называемые RACL (список контроля доступа на маршрутизаторе), позволяет фильтровать трафик, проходящий от одной сети к другой. Если рассматривать случай с VLAN, то RACL фильтруют трафик, передаваемый от одной VLAN к другой. Но не в состоянии позволить контролировать трафик проходящий внутри VLAN. Пока что, но это осуществимо.

Для этого обратимся к VACL (VLAN ACL), с помощью которых появляется возможность не только разрешать или запрещать трафик в пределах одной IP-сети, но и перенаправлять его на определенный интерфейс.

 

Топология

 

Как улучшить безопасность и настроить фильтрацию трафика внутри VLAN с помощью VACL

Начальные настройки на коммутаторе

 

hostname ALS
!
no ip domain lookup
!
line con 0
exec-t 0 0
logg sync
exit
!
vlan 10
exit
!
interface range fastEthernet0/1-48
switchport mode access
switchport access vlan 10
spanning-tree portfast
exit
!
interface vlan 10
ip address 192.168.1.10 255.255.255.0
no shutdown
exit

 

Проверим связь между устройствами:

 

ALS#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

ALS#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

ALS#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

 

Давайте теперь перейдем к VACL.

Цель настройки

Тогда как без VACL, три компьютера могут обмениваться данными без проблем, следует убедиться, что РС-1 может связываться с РС-2 и РС-3, но с условием отсутствия связи между РС-2 и РС-3.

Настройка VACL

По сути, принцип работы VACL схожий с тем, как работают дорожные карты. Это упорядоченный список правил, каждое с порядковым номером. Для каждого из этих правил нужно определить трафик в соответствии с записью “совпадение” (match), которому мы сопоставим “действие” (action), что может быть одним из следующих:

  • передача (forward): трафик обрабатывается нормально, следуя логике коммутации
  • сброс (drop): трафик отклонен
  • перенаправление (redirect): трафик перенаправляется в специальный интерфейс, несмотря на логику коммутации

Шаг 1: создать ACL (классический) для определения трафика

 

Обратите внимание на то, что здесь ACL используется для определения конкретного трафика. Поэтому необходимо правило “разрешение” (permit) соответственно тому, что будет затребовано, будь то отклонение или разрешение, независимо от действия. В данном случае идентифицируем трафик между РС-2 и РС-3, потому нужно его заблокировать. Значит должно быть правило разрешающее для того трафика, который подходит этому правилу:

 

ip access-list extended VLAN10
permit ip host 192.168.1.2 host 192.168.1.3
permit ip host 192.168.1.3 host 192.168.1.2
exit

 

Шаг 2: создать VACL для связи между “совпадение” и “действие”

 

Следовательно, приступим к созданию карты доступа VLAN (элемент соединяющий «действие» с «совпадениями»), в основе которой два правила:

  1. Трафик, захваченный ACL VLAN10, должен быть “отброшен” (порядковый номер 10)
  2. Остальной трафик должен быть передан (порядковый номер №20)

 

vlan access-map VMAP-VLAN10 10
match ip address VLAN10
action drop
exit
vlan access-map VMAP-VLAN10 20
action forward
exit

 

Шаг 3: применить к VACL к нужному VLAN

 

Остается только применить эти правила к VLAN10

 

vlan filter VMAP-VLAN10 vlan-list 10

 

Проверка настройки

 

Если всё прошло как планировалось, передача пакетов между РС-1 и РС-2, или между РС-1 и РС-3 должна функционировать, при том, что между РС-2 и РС-3 заблокирована.

 

C:Documents and SettingsPC-2>ping 192.168.1.3

Pinging 192.168.1.3 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.1.3:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

 

Всё работает как и планировалось. Так что мы совершили нечто невозможное для обычного ACL — настроили трафик внутри VLAN10.

 

Спасибо за уделенное время на прочтение статьи о том, как настроить фильтрацию трафика внутри VLAN на коммутаторе Cisco IOS с помощью VACL!

 

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Cisco, курсы по кибербезопасности, полный курс по кибербезопасности, курсы DevNet (программируемые сети) от Академии Cisco, курсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.
Новости

Больше похожих постов

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Самое читаемое
Меню