How-To-Install-PIP-to-Manage-Python-Packages-in-Linux

Как установить PIP для управления пакетами Python в Linux?

Рубрики:

Python

Метки:

, , ,

Pip (рекурсивная аббревиатура от «Pip Installs Packages» или «Pip Installs Python») — это кроссплатформенный менеджер пакетов для установки и управления пакетами Python (который можно найти в индексе пакетов Python (PyPI)), который поставляется с Python 2>= 2.7.9 или Python 3>= 3.4 двоичные файлы, которые загружаются с python.org.

В этой статье мы расскажем, как установить PIP в основных дистрибутивах Linux.

 

Примечание. Мы будем запускать все команды от имени пользователя root. Если вы управляете своей системой как обычный пользователь, то используйте команду sudo для получения привилегий root или вы также можете настроить систему для запуска команды sudo без ввода пароля, это возможно.

 

Установка PIP в системах Linux

Чтобы установить pip в Linux, выполните соответствующую команду для вашего дистрибутива следующим образом:

Установка PIP в Debian/Ubuntu

 

pip

 

Установка PIP на CentOS и RHEL

К сожалению, pip не упакован в официальные программные репозитории CentOS/RHEL. Поэтому вам нужно включить репозиторий EPEL, а затем установить его следующим образом:

 

 

Установка PIP на Fedora

 

 

Установка PIP на Arch Linux

 

 

Установка PIP на openSUSE

 

 

Как использовать PIP в системах Linux?

Для установки, удаления или поиска новых пакетов используйте эти команды (pip3 для python3 и pip для python2):

 

pip3 install

 

Чтобы увидеть список всех команд, введите:

 

pip3

 

В этой статье мы показали, как установить PIP в распространенных дистрибутивах Linux. Чтобы задать любые вопросы, касающиеся этой темы, воспользуйтесь формой обратной связи ниже.

 

Спасибо за уделенное время на прочтение статьи о PIP в системах Linux!

Если возникли вопросы, задавайте их в комментариях.

Подписывайтесь на обновления нашего блога и оставайтесь в курсе новостей мира инфокоммуникаций!

Чтобы знать больше и выделяться знаниями среди толпы IT-шников, записывайтесь на курсы Ciscoкурсы по кибербезопасности,  полный курс по кибербезопасностикурсы DevNet (программируемые сети) от Академии Ciscoкурсы Linux от Linux Professional Institute на платформе SEDICOMM University (Университет СЭДИКОММ).

Курсы Cisco и Linux с трудоустройством!

Спешите подать заявку! Осталось пару мест. Группы стартуют 22 июля, а следующая 19 августа, 23 сентября, 21 октября, 25 ноября, 16 декабря, 20 января, 24 февраля.
Что Вы получите?
  • Поможем стать экспертом в сетевом администрировании и получить международные сертификаты Cisco CCNA Routing & Switching или Linux LPI.
  • Предлагаем проверенную программу и учебник экспертов из Cisco Networking Academy и Linux Professional Institute, сертифицированных инструкторов и личного куратора.
  • Поможем с трудоустройством и сделать карьеру. 100% наших выпускников трудоустраиваются.
Как проходит обучение?
  • Проводим вечерние онлайн-лекции на нашей платформе или обучайтесь очно на базе Киевского офиса.
  • Спросим у вас об удобном времени для практик и подстроимся: понимаем, что времени учиться мало.
  • Если хотите индивидуальный график — обсудим и осуществим.
  • Выставим четкие дедлайны для самоорганизации. Личный куратор будет на связи, чтобы ответить на вопросы, проконсультировать и мотивировать придерживаться сроков сдачи экзаменов.
А еще поможем Вам:
  • отредактировать резюме;
  • подготовиться к техническим интервью;
  • подготовиться к конкурсу на понравившуюся вакансию;
  • устроим на работу в Cisco по программе Cisco Incubator, New Graduate и Experienced. Наши студенты, которые уже работают там: жмите на #НашиВCisco Вконтакте, #НашиВCisco Facebook.
Чтобы учиться на курсах Cisco CCNA Routing & Switching и Linux LPI, подайте заявку или получите бесплатную консультацию.

Рубрики:

Python

Метки:

, , ,

Больше похожих постов

2 комментария. Оставить новый

  • Условно, Тимур
    14 ноября 2020 19:08

    Как его удалить с Kali?
    Нужен 2 pip, а стоит pip3 – конфликтуют.
    Вот так это происходит:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package python-pip is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    python3-pip

    Ответить
  • У меня вот тот же вопрос…

    Ответить

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Заполните поле
Заполните поле
Пожалуйста, введите корректный адрес email.
Вы должны согласиться с условиями для продолжения

Поиск по сайту
Лучшее
Популярное
Рубрики

Свежие комментарии

Меню
Send this to a friend